imagebuilder: fix partition signature
authorMatthew Gyurgyik <matthew@gyurgyik.io>
Fri, 13 Nov 2020 19:21:29 +0000 (11:21 -0800)
committerPaul Spooren <mail@aparcar.org>
Sun, 27 Feb 2022 13:02:27 +0000 (14:02 +0100)
When building images with the imagebuilder, the partition signature
never changes. The signature is generated by hashing SOURCE_DATE_EPOCH
and LINUX_VERMAGIC which are undefined. Prepopulate these variables, as
done by the SDK.

Signed-off-by: Matthew Gyurgyik <matthew@gyurgyik.io>
(cherry picked from commit aab36200e7eb539afb18df74476132f4750a9f0b)

target/imagebuilder/Makefile

index 05c7cf3318deb18af1851524c533b1c47af52e1e..f1f25fc7c43558e1d246205cbbf17147370f79cd 100644 (file)
@@ -77,6 +77,8 @@ endif
                $(CP) -L $(LINUX_DIR)/arch/$(LINUX_KARCH)/boot/dts/* $(IB_DTSDIR); \
        fi
        $(SED) 's,^# REVISION:=.*,REVISION:=$(REVISION),g' $(PKG_BUILD_DIR)/include/version.mk
+       $(SED) 's,^# SOURCE_DATE_EPOCH:=.*,SOURCE_DATE_EPOCH:=$(SOURCE_DATE_EPOCH),g' $(PKG_BUILD_DIR)/include/version.mk
+       $(SED) '/LINUX_VERMAGIC:=/ { s,unknown,$(LINUX_VERMAGIC),g }' $(PKG_BUILD_DIR)/include/kernel.mk
        find $(PKG_BUILD_DIR) -name CVS -o -name .git -o -name .svn \
          | $(XARGS) rm -rf
        $(INSTALL_DIR) $(IB_IDIR)