cgi-io: cmake: enable extra compiler warnings
authorPetr Štetiar <ynezz@true.cz>
Fri, 11 Oct 2019 13:03:04 +0000 (15:03 +0200)
committerJohn Crispin <john@phrozen.org>
Fri, 11 Oct 2019 14:03:54 +0000 (16:03 +0200)
Spotting issues during compilation is cheaper.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
src/CMakeLists.txt

index 56d9fa7f1601f32589e6c98f5fac631573b0eb23..c7c9d40caa0761299bf63922782e9be9e753bf7f 100644 (file)
@@ -9,7 +9,8 @@ FIND_LIBRARY(ubox NAMES ubox)
 FIND_LIBRARY(ubus NAMES ubus)
 INCLUDE_DIRECTORIES(${ubus_include_dir})
 
-ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -Wmissing-declarations)
+ADD_DEFINITIONS(-Os -Wall -Werror -Wextra --std=gnu99 -g3)
+ADD_DEFINITIONS(-Wno-unused-parameter -Wmissing-declarations)
 
 SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")