Makefile: clean bl31_*.bin
authorJagan Teki <jagan@amarulasolutions.com>
Tue, 7 May 2019 18:52:11 +0000 (00:22 +0530)
committerKever Yang <kever.yang@rock-chips.com>
Wed, 26 Jun 2019 13:11:27 +0000 (21:11 +0800)
Rockchip platform has its python script that would generate various
bl31_*bin for creating u-boot.itb file by taking bl31.elf as input.

These bl31_*.bin files are generated in u-boot root directory and
have no rule to clean it up. so add support for it by adding in
command entry of clean target in Makefile.

Signed-off-by: Jagan Teki <jagan@amarulasolutions.com>
Reviewed-by: Kever Yang <kever.yang@rock-chips.com>
Makefile

index a90dd2a6052b2786e062106e1e60858f1665bb2b..db815316667aad1d54495db96cc90602e5762745 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1848,7 +1848,7 @@ clean: $(clean-dirs)
                -o -name 'dsdt.aml' -o -name 'dsdt.asl.tmp' -o -name 'dsdt.c' \
                -o -name '*.efi' -o -name '*.gcno' -o -name '*.so' \) \
                -type f -print | xargs rm -f \
-               image.map
+               bl31_*.bin image.map
 
 # mrproper - Delete all generated files, including .config
 #