rename <gsm0710muxd> to <fso-gsm0710muxd>, as it's fso-specific
authorMirko Vogt <mirko@openwrt.org>
Sat, 11 Jul 2009 07:25:14 +0000 (07:25 +0000)
committerMirko Vogt <mirko@openwrt.org>
Sat, 11 Jul 2009 07:25:14 +0000 (07:25 +0000)
SVN-Revision: 16773

phone/fso-gsm0710muxd/Makefile [new file with mode: 0644]
phone/fso-gsm0710muxd/files/gsm0710muxd.init [new file with mode: 0644]
phone/fso-gsm0710muxd/patches/010-fix-pm-searchpaths.patch [new file with mode: 0644]
phone/gsm0710muxd/Makefile [deleted file]
phone/gsm0710muxd/files/gsm0710muxd.init [deleted file]
phone/gsm0710muxd/patches/010-fix-pm-searchpaths.patch [deleted file]

diff --git a/phone/fso-gsm0710muxd/Makefile b/phone/fso-gsm0710muxd/Makefile
new file mode 100644 (file)
index 0000000..2077376
--- /dev/null
@@ -0,0 +1,62 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fso-gsm0710muxd
+PKG_VERSION:=20090121
+PKG_REV:=aae188c6b03d1fac8e4b5e4abe99235210ae6e25
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=git://git.freesmartphone.org/gsm0710muxd.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+
+include $(INCLUDE_DIR)/package.mk
+
+EXTRA_CFLAGS+=-I$(STAGING_DIR)/usr/lib/libintl/include -I$(STAGING_DIR)/usr/lib/libiconv/include
+EXTRA_LDFLAGS+=-lintl -L$(STAGING_DIR)/usr/lib/libintl/lib -liconv -L$(STAGING_DIR)/usr/lib/libiconv/lib
+
+define Package/fso-gsm0710muxd
+       SECTION:=phone
+       CATEGORY:=Phone
+       TITLE:=GSM multiplexing daemon
+       URL:=http://www.freesmartphone.org
+       DEPENDS:=+glib2 +dbus +libdbus-glib
+endef
+
+define Package/fso-gsm0710muxd/description
+       gsm0710muxd is a user space multiplexer for GSM according to the GSM 07.10 specification.
+endef
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR) && \
+               $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
+               $(CONFIGURE_VARS) \
+               ./autogen.sh \
+               $(CONFIGURE_ARGS_XTRA) \
+               $(CONFIGURE_ARGS) \
+       );
+endef
+
+define Build/Compile
+       DESTDIR=$(PKG_INSTALL_DIR) $(MAKE) -C $(PKG_BUILD_DIR) install
+       rm -f $(STAGING_DIR_HOST)/usr/bin/dbus-binding-tool
+endef
+
+define Package/fso-gsm0710muxd/install
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+       $(INSTALL_BIN) ./files/gsm0710muxd.init $(1)/etc/init.d/gsm0710muxd
+endef
+
+$(eval $(call BuildPackage,fso-gsm0710muxd))
+$(eval $(call RequireCommand,dbus-binding-tool, \
+       Command <dbus-binding-tool> not found - please install dbus-binding-tool \
+))
diff --git a/phone/fso-gsm0710muxd/files/gsm0710muxd.init b/phone/fso-gsm0710muxd/files/gsm0710muxd.init
new file mode 100644 (file)
index 0000000..3d42a5a
--- /dev/null
@@ -0,0 +1,11 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2008 OpenWrt.org
+START=70
+
+start() {
+    /usr/sbin/gsm0710muxd -d
+}
+    
+stop() {
+    killall gsm0710muxd
+}
diff --git a/phone/fso-gsm0710muxd/patches/010-fix-pm-searchpaths.patch b/phone/fso-gsm0710muxd/patches/010-fix-pm-searchpaths.patch
new file mode 100644 (file)
index 0000000..3f42042
--- /dev/null
@@ -0,0 +1,20 @@
+commit 08393b63026649c78b38082860b655ccf29e7598
+Author: Lars-Peter Clausen <lars@metafoo.de>
+Date:   Fri Jun 19 01:21:55 2009 +0200
+
+    Fix power management search paths.
+
+diff --git a/src/gsm0710muxd.c b/src/gsm0710muxd.c
+index f6aa2e0..e2cc400 100644
+--- a/src/gsm0710muxd.c
++++ b/src/gsm0710muxd.c
+@@ -1972,8 +1972,8 @@ int main(
+               struct stat sb;
+               int i;
+               static char* fn[] = {
++                      "/sys/bus/platform/devices/gta02-pm-gsm.0",
+                       "/sys/bus/platform/devices/neo1973-pm-gsm.0",
+-                      "/sys/bus/platform/devices/gta01-pm-gsm.0",
+                       NULL
+                       };
+               for (i=0;fn[i];i++)
diff --git a/phone/gsm0710muxd/Makefile b/phone/gsm0710muxd/Makefile
deleted file mode 100644 (file)
index 5707c62..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=gsm0710muxd
-PKG_VERSION:=20090121
-PKG_REV:=aae188c6b03d1fac8e4b5e4abe99235210ae6e25
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=git://git.freesmartphone.org/gsm0710muxd.git
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=$(PKG_REV)
-
-include $(INCLUDE_DIR)/package.mk
-
-EXTRA_CFLAGS+=-I$(STAGING_DIR)/usr/lib/libintl/include -I$(STAGING_DIR)/usr/lib/libiconv/include
-EXTRA_LDFLAGS+=-lintl -L$(STAGING_DIR)/usr/lib/libintl/lib -liconv -L$(STAGING_DIR)/usr/lib/libiconv/lib
-
-define Package/gsm0710muxd
-       SECTION:=phone
-       CATEGORY:=Phone
-       TITLE:=GSM multiplexing daemon
-       URL:=http://www.freesmartphone.org
-       DEPENDS:=+glib2 +dbus +libdbus-glib
-endef
-
-define Package/gsm0710muxd/description
-       gsm0710muxd is a user space multiplexer for GSM according to the GSM 07.10 specification.
-endef
-
-define Build/Configure
-       (cd $(PKG_BUILD_DIR) && \
-               $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
-               $(CONFIGURE_VARS) \
-               ./autogen.sh \
-               $(CONFIGURE_ARGS_XTRA) \
-               $(CONFIGURE_ARGS) \
-       );
-endef
-
-define Build/Compile
-       DESTDIR=$(PKG_INSTALL_DIR) $(MAKE) -C $(PKG_BUILD_DIR) install
-       rm -f $(STAGING_DIR_HOST)/usr/bin/dbus-binding-tool
-endef
-
-define Package/gsm0710muxd/install
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
-       $(INSTALL_BIN) ./files/gsm0710muxd.init $(1)/etc/init.d/gsm0710muxd
-endef
-
-$(eval $(call BuildPackage,gsm0710muxd))
-$(eval $(call RequireCommand,dbus-binding-tool, \
-       Command <dbus-binding-tool> not found - please install dbus-binding-tool \
-))
diff --git a/phone/gsm0710muxd/files/gsm0710muxd.init b/phone/gsm0710muxd/files/gsm0710muxd.init
deleted file mode 100644 (file)
index 3d42a5a..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2008 OpenWrt.org
-START=70
-
-start() {
-    /usr/sbin/gsm0710muxd -d
-}
-    
-stop() {
-    killall gsm0710muxd
-}
diff --git a/phone/gsm0710muxd/patches/010-fix-pm-searchpaths.patch b/phone/gsm0710muxd/patches/010-fix-pm-searchpaths.patch
deleted file mode 100644 (file)
index 3f42042..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-commit 08393b63026649c78b38082860b655ccf29e7598
-Author: Lars-Peter Clausen <lars@metafoo.de>
-Date:   Fri Jun 19 01:21:55 2009 +0200
-
-    Fix power management search paths.
-
-diff --git a/src/gsm0710muxd.c b/src/gsm0710muxd.c
-index f6aa2e0..e2cc400 100644
---- a/src/gsm0710muxd.c
-+++ b/src/gsm0710muxd.c
-@@ -1972,8 +1972,8 @@ int main(
-               struct stat sb;
-               int i;
-               static char* fn[] = {
-+                      "/sys/bus/platform/devices/gta02-pm-gsm.0",
-                       "/sys/bus/platform/devices/neo1973-pm-gsm.0",
--                      "/sys/bus/platform/devices/gta01-pm-gsm.0",
-                       NULL
-                       };
-               for (i=0;fn[i];i++)