ipq40xx: DTS style updates for OpenMesh devices
authorSven Eckelmann <sven@narfation.org>
Sun, 22 Nov 2020 19:09:27 +0000 (20:09 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 23 Nov 2020 12:44:47 +0000 (13:44 +0100)
The OpenMesh related files were not updated since a while and the new
coding style requirements weren't integrated. This can cause problems
for new devices when an author uses these files as starting point.

* use SPDX-License-Identifiers instead of full license texts
* drop linux,default-trigger with value default-off for LEDs
* led nodes with label "abc:xyz" should have name "xyz_abc"
* led DT labels for "xyz_abc" should be "led_xyz_abc"
* "m25p80@0" flash node should be renamed to "flash@0"
* drop unnecessary empty lines

Signed-off-by: Sven Eckelmann <sven@narfation.org>
[minor commit title and message adjustments]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-a42.dts
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-a62.dts
target/linux/ipq40xx/image/Makefile

index d866f8dd1a131eaa0d4d890ff3396d41f95148ac..f571da510eea6d84d086c2ff06013ac8d91a7abd 100644 (file)
@@ -1,18 +1,6 @@
+// SPDX-License-Identifier: ISC
 /* Copyright (c) 2015, The Linux Foundation. All rights reserved.
  * Copyright (c) 2017, Sven Eckelmann <sven.eckelmann@openmesh.com>
- *
- * Permission to use, copy, modify, and/or distribute this software for any
- * purpose with or without fee is hereby granted, provided that the above
- * copyright notice and this permission notice appear in all copies.
- *
- * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
- * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
- * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
- * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
- * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
- * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
- * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
- *
  */
 
 #include "qcom-ipq4019.dtsi"
        };
 
        aliases {
-               led-boot = &power;
-               led-failsafe = &power;
-               led-running = &power;
-               led-upgrade = &power;
+               led-boot = &led_status_green;
+               led-failsafe = &led_status_green;
+               led-running = &led_status_green;
+               led-upgrade = &led_status_green;
        };
 
        leds {
                compatible = "gpio-leds";
 
-               red {
+               status_red {
                        label = "red:status";
                        gpios = <&tlmm 0 GPIO_ACTIVE_HIGH>;
-                       linux,default-trigger = "default-off";
                };
 
-               power: green {
+               led_status_green: status_green {
                        label = "green:status";
                        gpios = <&tlmm 1 GPIO_ACTIVE_HIGH>;
                };
 
-               blue {
+               status_blue {
                        label = "blue:status";
                        gpios = <&tlmm 2 GPIO_ACTIVE_HIGH>;
-                       linux,default-trigger = "default-off";
                };
        };
 
        status = "okay";
        cs-gpios = <&tlmm 54 GPIO_ACTIVE_HIGH>;
 
-       m25p80@0 {
+       flash@0 {
                #address-cells = <1>;
                #size-cells = <1>;
                compatible = "jedec,spi-nor";
index 4c14f41b3418f195aac86d65517179a2ff15553e..279050fa158f6a14970f12480866de2af3a8af6f 100644 (file)
@@ -1,18 +1,6 @@
+// SPDX-License-Identifier: ISC
 /* Copyright (c) 2015, The Linux Foundation. All rights reserved.
  * Copyright (c) 2017-2018, Sven Eckelmann <sven.eckelmann@openmesh.com>
- *
- * Permission to use, copy, modify, and/or distribute this software for any
- * purpose with or without fee is hereby granted, provided that the above
- * copyright notice and this permission notice appear in all copies.
- *
- * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
- * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
- * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
- * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
- * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
- * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
- * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
- *
  */
 
 #include "qcom-ipq4019.dtsi"
        };
 
        aliases {
-               led-boot = &power;
-               led-failsafe = &power;
-               led-running = &power;
-               led-upgrade = &power;
+               led-boot = &led_status_green;
+               led-failsafe = &led_status_green;
+               led-running = &led_status_green;
+               led-upgrade = &led_status_green;
        };
 
        leds {
                compatible = "gpio-leds";
 
-               red {
+               status_red {
                        label = "red:status";
                        gpios = <&tlmm 43 GPIO_ACTIVE_HIGH>;
-                       linux,default-trigger = "default-off";
                };
 
-               power: green {
+               led_status_green: status_green {
                        label = "green:status";
                        gpios = <&tlmm 45 GPIO_ACTIVE_HIGH>;
                };
 
-               blue {
+               status_blue {
                        label = "blue:status";
                        gpios = <&tlmm 46 GPIO_ACTIVE_HIGH>;
-                       linux,default-trigger = "default-off";
                };
        };
 
        status = "okay";
        cs-gpios = <&tlmm 12 GPIO_ACTIVE_HIGH>;
 
-       m25p80@0 {
+       flash@0 {
                #address-cells = <1>;
                #size-cells = <1>;
                compatible = "jedec,spi-nor";
index 142896bde8fdc228977282f1db57bb65da7515c8..d4188f5282fc772a7f46203494320f889bbc42f6 100644 (file)
@@ -647,7 +647,6 @@ define Device/openmesh_a62
        IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
        DEVICE_PACKAGES := ath10k-firmware-qca9888-ct uboot-envtools
 endef
-
 TARGET_DEVICES += openmesh_a62
 
 define Device/qcom_ap-dk01.1-c1