kernel: bump 4.14 to 4.14.123
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 3 Jun 2019 11:40:15 +0000 (13:40 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 3 Jun 2019 15:00:29 +0000 (17:00 +0200)
Refreshed all patches.

Compile-tested on: ar71xx, cns3xxx, imx6, x86_64
Runtime-tested on: ar71xx, cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.14/950-0136-cgroup-Disable-cgroup-memory-by-default.patch
target/linux/cns3xxx/patches-4.14/075-spi_support.patch
target/linux/generic/hack-4.14/911-kobject_add_broadcast_uevent.patch
target/linux/layerscape/patches-4.14/301-arch-support-layerscape.patch
target/linux/layerscape/patches-4.14/819-sdhc-support-layerscape.patch
target/linux/layerscape/patches-4.14/824-mmc-sdhci-of-esdhc-add-voltage-switch-support-for-ls.patch

index 2c5c4016ca47f5717bd57d6f2c66ee1a0fa2e8a9..b73d408556f04916ed0be8b50cb351b903de7452 100644 (file)
@@ -7,11 +7,11 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-4.9 = .180
-LINUX_VERSION-4.14 = .122
+LINUX_VERSION-4.14 = .123
 LINUX_VERSION-4.19 = .46
 
 LINUX_KERNEL_HASH-4.9.180 = d25a490d62a3e96a587333e163862585eac4086fc8d4893b4ec1711e7d387c5f
-LINUX_KERNEL_HASH-4.14.122 = c8a3f40ef877e18b3d2890e0954f2d81b6d012a7321836ca4e5b036ef93f68f5
+LINUX_KERNEL_HASH-4.14.123 = 25f58cb56bde388ac9bcee984f5f2d0ca094b0a8af6b92ad1f5b2fd0e6725b85
 LINUX_KERNEL_HASH-4.19.46 = 097b52fe8a872259f4a3dba571b2eaf7b9863d9cde5399c6b316dec0ef57e67a
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index eb85fe6439804feffa2e10b4d46f134b7b04996a..e231841d88478f2b72a3c142bd6764febe2b22e2 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/kernel/cgroup/cgroup.c
 +++ b/kernel/cgroup/cgroup.c
-@@ -5162,6 +5162,8 @@ int __init cgroup_init_early(void)
+@@ -5168,6 +5168,8 @@ int __init cgroup_init_early(void)
  }
  
  static u16 cgroup_disable_mask __initdata;
@@ -26,7 +26,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  
  /**
   * cgroup_init - cgroup initialization
-@@ -5200,6 +5202,12 @@ int __init cgroup_init(void)
+@@ -5206,6 +5208,12 @@ int __init cgroup_init(void)
  
        mutex_unlock(&cgroup_mutex);
  
@@ -39,7 +39,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        for_each_subsys(ss, ssid) {
                if (ss->early_init) {
                        struct cgroup_subsys_state *css =
-@@ -5583,6 +5591,28 @@ static int __init cgroup_disable(char *s
+@@ -5589,6 +5597,28 @@ static int __init cgroup_disable(char *s
  }
  __setup("cgroup_disable=", cgroup_disable);
  
index e38dbdb75e10b21711ea5d8a53499616ac5bc44f..401ec876e92474c37c921771db4f9f84dd274d65 100644 (file)
@@ -39,7 +39,7 @@
  /**
 --- a/drivers/spi/spi.c
 +++ b/drivers/spi/spi.c
-@@ -1027,6 +1027,9 @@ static int spi_transfer_one_message(stru
+@@ -1029,6 +1029,9 @@ static int spi_transfer_one_message(stru
        list_for_each_entry(xfer, &msg->transfers, transfer_list) {
                trace_spi_transfer_start(msg, xfer);
  
index 19400af189653bedf47455a432019dc62db050a9..bf46428854194c0c34915ad956b1bb526ba20978 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #endif /* _KOBJECT_H_ */
 --- a/lib/kobject_uevent.c
 +++ b/lib/kobject_uevent.c
-@@ -599,6 +599,43 @@ int add_uevent_var(struct kobj_uevent_en
+@@ -602,6 +602,43 @@ int add_uevent_var(struct kobj_uevent_en
  EXPORT_SYMBOL_GPL(add_uevent_var);
  
  #if defined(CONFIG_NET)
index 970e95cf3b2ee9c6cc3524ee251135361f4d565a..2fa6e4797efe6257f961643a8a114881a81a376a 100644 (file)
@@ -290,7 +290,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
  #define __HAVE_PHYS_MEM_ACCESS_PROT
 --- a/arch/arm64/mm/dma-mapping.c
 +++ b/arch/arm64/mm/dma-mapping.c
-@@ -937,3 +937,4 @@ void arch_setup_dma_ops(struct device *d
+@@ -947,3 +947,4 @@ void arch_setup_dma_ops(struct device *d
        }
  #endif
  }
index ed72f31e4a595d72d8f74d6026d8550a79970d13..f5fc0545bea243ff9bf4843f47aa16762b34e59c 100644 (file)
@@ -112,7 +112,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
  
        temp = sdhci_readl(host, ESDHC_SYSTEM_CONTROL);
        temp &= ~(ESDHC_CLOCK_SDCLKEN | ESDHC_CLOCK_IPGEN | ESDHC_CLOCK_HCKEN |
-@@ -797,6 +830,7 @@ static struct soc_device_attribute soc_i
+@@ -800,6 +833,7 @@ static struct soc_device_attribute soc_i
  
  static void esdhc_init(struct platform_device *pdev, struct sdhci_host *host)
  {
@@ -120,7 +120,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
        struct sdhci_pltfm_host *pltfm_host;
        struct sdhci_esdhc *esdhc;
        struct device_node *np;
-@@ -816,6 +850,9 @@ static void esdhc_init(struct platform_d
+@@ -819,6 +853,9 @@ static void esdhc_init(struct platform_d
        else
                esdhc->quirk_incorrect_hostver = false;
  
@@ -130,7 +130,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
        np = pdev->dev.of_node;
        clk = of_clk_get(np, 0);
        if (!IS_ERR(clk)) {
-@@ -915,14 +952,6 @@ static int sdhci_esdhc_probe(struct plat
+@@ -923,14 +960,6 @@ static int sdhci_esdhc_probe(struct plat
        return ret;
  }
  
index 7a276d8abd5575246bbf201c992297cde86a54ca..969fe3f375963dd0de8434d50510df646a46adc2 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
 
 --- a/drivers/mmc/host/sdhci-of-esdhc.c
 +++ b/drivers/mmc/host/sdhci-of-esdhc.c
-@@ -658,6 +658,7 @@ static void esdhc_reset(struct sdhci_hos
+@@ -661,6 +661,7 @@ static void esdhc_reset(struct sdhci_hos
  static const struct of_device_id scfg_device_ids[] = {
        { .compatible = "fsl,t1040-scfg", },
        { .compatible = "fsl,ls1012a-scfg", },