refpolicy: fix path to setfiles and checkpolicy
authorPaul Spooren <mail@aparcar.org>
Tue, 29 Sep 2020 09:09:22 +0000 (23:09 -1000)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 30 Sep 2020 02:26:12 +0000 (03:26 +0100)
Directly set path via MAKE vars instead of defning TESTTOOLS. This way
setfiles, which is required by the ImageBuilder, ends up in /host/bin
while checkpolicy can stay in hostpkg/bin.

Signed-off-by: Paul Spooren <mail@aparcar.org>
package/system/refpolicy/Makefile

index a80b4d043c4c5b4754f145f3b10cc0e8fc1fb673..a43177095517c6023a3f9477e7fb335c4a2f95df 100644 (file)
@@ -56,9 +56,8 @@ endef
 # builds is a small host tool that gets run as part of the build
 # process.
 MAKE_FLAGS += \
-       TEST_TOOLCHAIN="$(STAGING_DIR_HOSTPKG)" \
-       BINDIR=/bin \
-       SBINDIR=/sbin \
+       SETFILES="$(STAGING_DIR_HOST)/bin/setfiles" \
+       CHECKPOLICY="$(STAGING_DIR_HOSTPKG)/bin/checkpolicy" \
        CC="$(HOSTCC)" \
        CFLAGS="$(HOST_CFLAGS)"