ath79: add WWAN serial driver and qmi for GL.iNET GL-E750 (Mudi)
authorJan Fuchs <jf@simonwunderlich.de>
Thu, 25 Jan 2024 10:29:21 +0000 (11:29 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 2 Feb 2024 10:29:52 +0000 (11:29 +0100)
The driver for the cellular modems serial interface and qmi was missing
from the default device packages. The driver is required to interact
with the modem using AT commands.

Signed-off-by: Jan Fuchs <jf@simonwunderlich.de>
target/linux/ath79/image/nand.mk

index bf2b1a1f8ab15e869a58130583d9d1ff0df0de2c..0b51982c4fa79f2b82d57b89ad2a95da87df52d9 100644 (file)
@@ -190,7 +190,8 @@ define Device/glinet_gl-e750
   SOC := qca9531
   DEVICE_VENDOR := GL.iNet
   DEVICE_MODEL := GL-E750
-  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9887-ct kmod-usb2
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9887-ct kmod-usb2 \
+       kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
   SUPPORTED_DEVICES += gl-e750
   KERNEL_SIZE := 4096k
   IMAGE_SIZE := 131072k