package/base-files-network: use new service wrappers
authorNicolas Thill <nico@openwrt.org>
Tue, 8 Nov 2011 22:47:54 +0000 (22:47 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 8 Nov 2011 22:47:54 +0000 (22:47 +0000)
SVN-Revision: 28866

package/base-files-network/Makefile
package/base-files-network/files/lib/network/config.sh

index 78c9981e6b48f9b8874ac34c0e58fb7cdcaa15f7..ead94580986910a2c4f7dbe990d6ce808faa2eab 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files-network
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_BUILD_DEPENDS:=opkg/host
 
index 74810e47d0aa3756c8739a7e4bf948e084f18edb..da45089dffcfb7a69532721d738f0693a642954a 100755 (executable)
@@ -1,5 +1,5 @@
 #!/bin/sh
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 
 # DEBUG="echo"
 
@@ -368,7 +368,9 @@ setup_interface() {
                dhcp)
                        # kill running udhcpc instance
                        local pidfile="/var/run/dhcp-${iface}.pid"
-                       service_kill udhcpc "$pidfile"
+
+                       SERVICE_PID_FILE="$pidfile" \
+                       service_stop udhcpc
 
                        local ipaddr netmask hostname proto1 clientid vendorid broadcast reqopts
                        config_get ipaddr "$config" ipaddr
@@ -393,7 +395,8 @@ setup_interface() {
                        [ "$proto1" != "$proto" ] && append dhcpopts "-n -q" || append dhcpopts "-O rootpath -R &"
                        [ "$broadcast" = 1 ] && broadcast="-O broadcast" || broadcast=
 
-                       $DEBUG eval udhcpc -t 0 -i "$iface" \
+                       SERVICE_PID_FILE="$pidfile" \
+                       service_start /sbin/udhcpc -t 0 -i "$iface" \
                                ${ipaddr:+-r $ipaddr} \
                                ${hostname:+-H $hostname} \
                                ${clientid:+-c $clientid} \
@@ -426,8 +429,8 @@ stop_interface_dhcp() {
 
        remove_dns "$config"
 
-       local pidfile="/var/run/dhcp-${ifname}.pid"
-       service_kill udhcpc "$pidfile"
+       SERVICE_PID_FILE="/var/run/dhcp-${ifname}.pid" \
+       service_stop /sbin/udhcpc
 
        uci -P /var/state revert "network.$config"
 }