include: export staging_dir/host/bin path from within host.mk (#18957)
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 10 Feb 2015 15:49:17 +0000 (15:49 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 10 Feb 2015 15:49:17 +0000 (15:49 +0000)
We need to do that to pickup the prereq-build prepared symlinks for auxillary
operations like metadata scanning.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44378

include/host.mk

index 4ca81400e965ba9c32b3761f33533d2a46bb29be..f7368de85c2b6e8fe7e0059d23bdee1fa037b4b2 100644 (file)
@@ -13,6 +13,8 @@ endif
 ifneq ($(__host_inc),1)
 __host_inc:=1
 
+export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
+
 try-run = $(shell set -e; \
        TMP_F="$(TMP_DIR)/try-run.$$$$.tmp"; \
        if ($(1)) >/dev/null 2>&1; then echo "$(2)"; else echo "$(3)"; fi; \