Support for Solos PCI ADSL2+ modem This driver is used by Traverse Technologies'...
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 15 Sep 2010 03:52:13 +0000 (03:52 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 15 Sep 2010 03:52:13 +0000 (03:52 +0000)
http://www.traverse.com.au/productview.php?product_id=117

Signed-off-by: Nathan Williams <nathan@traverse.com.au>
SVN-Revision: 23070

package/kernel/modules/netdevices.mk

index 69ec517adbbccc65d3923b1234d62e1dad6d7b71..aaee3acce8a61b2e4f091682adf8e5dc6b7ba5f3 100644 (file)
@@ -484,3 +484,20 @@ define KernelPackage/tulip/description
 endef
 
 $(eval $(call KernelPackage,tulip))
+
+
+define KernelPackage/solos-pci
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=Solos ADSL2+ multiport modem
+  DEPENDS:=@TARGET_x86
+  KCONFIG:=CONFIG_ATM_SOLOS
+  FILES:=$(LINUX_DIR)/drivers/atm/solos-pci.ko
+  AUTOLOAD:=$(call AutoLoad,50,solos-pci)
+endef
+
+define KernelPackage/solos-pci/description
+ Kernel module for Traverse Technologies' Solos PCI cards
+ and Geos ADSL2+ x86 motherboard.
+endef
+
+$(eval $(call KernelPackage,solos-pci))