build: select procd-seccomp if kernel support is present
authorDaniel Golle <daniel@makrotopia.org>
Fri, 6 Nov 2020 02:10:28 +0000 (02:10 +0000)
committerPaul Spooren <mail@aparcar.org>
Fri, 8 Oct 2021 09:22:18 +0000 (23:22 -1000)
Install ld-preload hooks allowing to add seccomp filters for arbitrary
services if kernel support for seccomp is present.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
include/target.mk

index eac2d164c3badf2e5a55691808465ab397b86fb8..03192d3ebef4904851f8b798aa1bffa279a6036e 100644 (file)
@@ -38,6 +38,11 @@ ifeq ($(CONFIG_SMALL_FLASH),)
 DEFAULT_PACKAGES+=procd-ujail
 endif
 
+# include seccomp ld-preload hooks if kernel supports it
+ifneq ($(CONFIG_KERNEL_SECCOMP),)
+DEFAULT_PACKAGES+=procd-seccomp
+endif
+
 # For the basic set
 DEFAULT_PACKAGES.basic:=
 # For nas targets