f2fstools: set each library package VARIANT
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Sun, 17 Oct 2021 15:34:05 +0000 (12:34 -0300)
committerFelix Fietkau <nbd@nbd.name>
Mon, 1 Nov 2021 19:18:55 +0000 (20:18 +0100)
Set the different libf2fs packages's VARIANT, so that the right settings
will be used by each different variant, if they are both being built.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
package/utils/f2fs-tools/Makefile

index 0d243302c23e0b36297c1beb3acf78203c339718..44ab63c403a39969569636d77dfb001c13735ea6 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=f2fs-tools
 PKG_VERSION:=1.14.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git/snapshot/
@@ -85,6 +85,7 @@ define Package/libf2fs
   DEPENDS:=+libuuid
   ABI_VERSION:=6
   CONFLICTS:=libf2fs-selinux
+  VARIANT:=default
 endef
 
 define Package/libf2fs-selinux
@@ -93,6 +94,7 @@ define Package/libf2fs-selinux
   TITLE:=Library for Flash-Friendly File System (F2FS) tools with SELinux support
   DEPENDS:=+libuuid +libselinux
   ABI_VERSION:=6
+  VARIANT:=selinux
 endef
 
 CONFIGURE_ARGS += \