bcm47xx: relocate LZMA loader
authorRafał Miłecki <rafal@milecki.pl>
Sun, 7 Nov 2021 13:45:14 +0000 (14:45 +0100)
committerRafał Miłecki <rafal@milecki.pl>
Mon, 8 Nov 2021 14:55:26 +0000 (15:55 +0100)
Kernel 5.10 grew bigger than 5.4 so we need to bump BZ_TEXT_START to
allow lzma loader hanel its size.

At the same time BZ_STACK_START needs to be increased to avoid
overwriting the stack.

For a reference see:
d5cf4a5aa4a3 ("brcm47xx: relocate loader to higher address")
2909a4b78e2b ("brcm47xx: relocate the stack in loader")

Cc: Hauke Mehrtens <hauke@hauke-m.de>
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Acked-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/bcm47xx/image/lzma-loader/src/Makefile

index a08fc05b9fc22df0c0a748e67735439ddc095f58..a3e7ae1c92ee0785f1a547ba24673b652cd8a44e 100644 (file)
@@ -18,8 +18,8 @@
 #
 
 TEXT_START     := 0x80001000
-BZ_TEXT_START  := 0x80600000
-BZ_STACK_START := 0x80700000
+BZ_TEXT_START  := 0x80700000
+BZ_STACK_START := 0x80800000
 
 OBJCOPY                := $(CROSS_COMPILE)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S