kernel: modules: don't override NLS dependencies
authorDaniel Golle <daniel@makrotopia.org>
Mon, 11 Mar 2024 23:23:23 +0000 (23:23 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 11 Mar 2024 23:49:25 +0000 (23:49 +0000)
Recent changes for Linux 6.6 broke things when building with older
kernels:
Package kmod-fs-jfs is missing dependencies for the following libraries:
nls_base.ko

Fix this by adding NLS dependencies after the added dependency applying
on Linux 6.6.

Fixes: f9198480da ("kernel: modules: fs: adapt for kernel 6.6")
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/kernel/linux/modules/fs.mk

index 8f1ed414849af95642fd1bf3063d5902f00863b5..0d98c5a6815166f3e0dbc868348b1465636eaaa2 100644 (file)
@@ -344,8 +344,8 @@ define KernelPackage/fs-jfs
   KCONFIG:=CONFIG_JFS_FS
   FILES:=$(LINUX_DIR)/fs/jfs/jfs.ko
   AUTOLOAD:=$(call AutoLoad,30,jfs,1)
-  $(call AddDepends/nls)
   DEPENDS:=+LINUX_6_6:kmod-nls-ucs2-utils
+  $(call AddDepends/nls)
 endef
 
 define KernelPackage/fs-jfs/description