iproute2: update to 5.14
authorHans Dedecker <dedeckeh@gmail.com>
Sat, 11 Sep 2021 19:17:39 +0000 (21:17 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Sat, 18 Sep 2021 18:59:31 +0000 (20:59 +0200)
Update iproute2 to latest stable 5.14; for the changes see https://lwn.net/Articles/867940/

Refresh patches

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/network/utils/iproute2/Makefile
package/network/utils/iproute2/patches/100-configure.patch
package/network/utils/iproute2/patches/140-keep_libmnl_optional.patch
package/network/utils/iproute2/patches/145-keep_libelf_optional.patch
package/network/utils/iproute2/patches/150-keep_libcap_optional.patch
package/network/utils/iproute2/patches/170-ip_tiny.patch
package/network/utils/iproute2/patches/180-drop_FAILED_POLICY.patch
package/network/utils/iproute2/patches/190-fix-nls-rpath-link.patch
package/network/utils/iproute2/patches/200-drop_libbsd_dependency.patch
package/network/utils/iproute2/patches/300-selinux-configurable.patch

index 1cd4833aba0ed73bd32c9878b2f4b42d7f546ce0..cfcdb8cc53b73856794b3107a9f522af60b5a4fe 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
-PKG_VERSION:=5.13.0
+PKG_VERSION:=5.14.0
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
-PKG_HASH:=72a2e53774cac9e65f7b617deebb2059f87e8960d6e9713e4d788cea966f1b36
+PKG_HASH:=210fa785a52f3763c4287fd5ae63e246f6311bfaa48c424baab6d383bb7591d4
 PKG_BUILD_PARALLEL:=1
 PKG_BUILD_DEPENDS:=iptables
 PKG_LICENSE:=GPL-2.0
index f70b7199b66a4042dff3750f08eb17110065be7e..0c19b2086a95bce170e56cf199a8c5fa5e86082f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -39,7 +39,8 @@ int main(int argc, char **argv) {
+@@ -34,7 +34,8 @@ int main(int argc, char **argv) {
  }
  EOF
  
index a11a2a3fab2025ea416ce81add651abebbd0d166..ff7e9ca4e58f9904fbc009c4d58e5aec1fff448a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -367,7 +367,7 @@ check_selinux()
+@@ -387,7 +387,7 @@ check_selinux()
  
  check_mnl()
  {
index c780022d1ad48b3a829258ddbe9340b5fc193de4..079ca0512e212d65bcf916053b4e9adbd9dc1600 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -235,7 +235,7 @@ EOF
+@@ -255,7 +255,7 @@ EOF
  
  check_elf()
  {
index 8cd4e4ae6aa8e3d35c5bd8f22f65c9dba8ff0e14..68e16241663c30616c97a78f16234f5f7b8c9373 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -425,7 +425,7 @@ EOF
+@@ -445,7 +445,7 @@ EOF
  
  check_cap()
  {
index a0dde748c7e3140340eac98c58c35245a0d9fb69..2c1ec1dcb36055025b8f9b28178a620019ca0741 100644 (file)
                "Usage: ip [ OPTIONS ] OBJECT { COMMAND | help }\n"
                "       ip [ -force ] -batch filename\n"
 +#ifndef IPROUTE2_TINY
-               "where  OBJECT := { address | addrlabel | fou | help | ila | l2tp | link |\n"
-               "                   macsec | maddress | monitor | mptcp | mroute | mrule |\n"
-               "                   neighbor | neighbour | netconf | netns | nexthop | ntable |\n"
-               "                   ntbl | route | rule | sr | tap | tcpmetrics |\n"
-               "                   token | tunnel | tuntap | vrf | xfrm }\n"
+               "where  OBJECT := { address | addrlabel | fou | help | ila | l2tp | link |\n"
+               "                   macsec | maddress | monitor | mptcp | mroute | mrule |\n"
+               "                   neighbor | neighbour | netconf | netns | nexthop | ntable |\n"
+               "                   ntbl | route | rule | sr | tap | tcpmetrics |\n"
+               "                   token | tunnel | tuntap | vrf | xfrm }\n"
 +#else
 +              "where  OBJECT := { address | ila | link | macsec | maddress | monitor |\n"
 +              "                   mroute | mrule | neighbor | neighbour | netns | route |\n"
@@ -43,7 +43,7 @@
                "       OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n"
                "                    -h[uman-readable] | -iec | -j[son] | -p[retty] |\n"
                "                    -f[amily] { inet | inet6 | mpls | bridge | link } |\n"
-@@ -90,36 +96,50 @@ static const struct cmd {
+@@ -91,36 +97,50 @@ static const struct cmd {
        int (*func)(int argc, char **argv);
  } cmds[] = {
        { "address",    do_ipaddr },
index 95b37ae4426c2e0d4672e816c52adf526a0e7d8f..07d5230a6e4b408a30f1f79b6d46556ef44b8edf 100644 (file)
@@ -31,7 +31,7 @@ Subject: [PATCH] add support for dropping with FAILED_POLICY
                if (!end || end == arg || *end || res > 255)
 --- a/include/uapi/linux/rtnetlink.h
 +++ b/include/uapi/linux/rtnetlink.h
-@@ -249,6 +249,7 @@ enum {
+@@ -256,6 +256,7 @@ enum {
        RTN_THROW,              /* Not in this table            */
        RTN_NAT,                /* Translate this address       */
        RTN_XRESOLVE,           /* Use external resolver        */
index d0f8cec633175dfae5d69bc5f1b7e2e440f8d9f8..92d02b9a4e93180a321fa83ea5aacba7f141db8b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -259,7 +259,7 @@ int main(int argc, char **argv) {
+@@ -279,7 +279,7 @@ int main(int argc, char **argv) {
  }
  EOF
  
@@ -9,7 +9,7 @@
      local ret=$?
  
      rm -f $TMPDIR/libbpf_test.c $TMPDIR/libbpf_test
-@@ -277,7 +277,7 @@ int main(int argc, char **argv) {
+@@ -297,7 +297,7 @@ int main(int argc, char **argv) {
  }
  EOF
  
index bf335e0800986be269d3cb4b79b07a21ce68b09c..12a1ccfa33cf1adc4e8d8c25bab96e5bf4965a02 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -411,14 +411,8 @@ EOF
+@@ -431,14 +431,8 @@ EOF
      if $CC -I$INCLUDE -o $TMPDIR/strtest $TMPDIR/strtest.c >/dev/null 2>&1; then
        echo "no"
      else
index 33c5279aec9f194c1fbed07008973c852ef489c2..b7e61fd3bd593791c66e03d3be1299dc023949f0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -354,7 +354,7 @@ check_libbpf()
+@@ -374,7 +374,7 @@ check_libbpf()
  check_selinux()
  # SELinux is a compile time option in the ss utility
  {