depends.mk: fix typo in rdep function
authorMichael Pratt <mcpratt@pm.me>
Fri, 9 Sep 2022 20:01:21 +0000 (16:01 -0400)
committerChristian Marangi <ansuelsmth@gmail.com>
Sun, 11 Sep 2022 09:07:53 +0000 (11:07 +0200)
Just like later in the file,
the precursor to <stampfile>_check
<stampfile>_check.1 is supposed to be moved to
<stampfile>_check before it is touched.

This line would error if it was ever run.

Signed-off-by: Michael Pratt <mcpratt@pm.me>
include/depends.mk

index 465e4e952a9a546c5729a20d3eb8746179941e2f..073fb03632ba309f42f90fc5388068eb33fd08e3 100644 (file)
@@ -27,7 +27,7 @@ ifneq ($(wildcard $(2)),)
                { [ \! -f "$(3)" ] || diff $(3) $(3).1 >/dev/null; } && \
        ) \
        { \
-               [ -f "$(2)_check.1" ] && mv "$(2)_check.1"; \
+               [ -f "$(2)_check.1" ] && mv "$(2)_check.1" "$(2)_check"; \
            $(TOPDIR)/scripts/timestamp.pl $(DEP_FINDPARAMS) $(4) -n $(2) $(1) && { \
                        $(call debug_eval,$(SUBDIR),r,echo "No need to rebuild $(2)";) \
                        touch -r "$(2)" "$(2)_check"; \