build: allow var.% targets to bypass the prepare steps
authorMichael Pratt <mcpratt@pm.me>
Tue, 17 May 2022 21:50:23 +0000 (17:50 -0400)
committerChristian Marangi <ansuelsmth@gmail.com>
Fri, 5 Jan 2024 15:25:13 +0000 (16:25 +0100)
These targets are used to input variable values from the Make
context into other things like python scripts, so log messages
should be silenced and build prerequisites should be skipped.

The same thing is done for the other variable print target "val.%".

While at it, combine identical target rules into one definition.

Signed-off-by: Michael Pratt <mcpratt@pm.me>
include/toplevel.mk

index 328214be1bc59fedd17a8cbcb339b364e9f5ec9f..96f32139d986432750fdc8be181dac7e63a39dc7 100644 (file)
@@ -210,9 +210,7 @@ prereq:: prepare-tmpinfo .config
        @+$(NO_TRACE_MAKE) -r -s $@
 
 check: .config FORCE
-       @+$(NO_TRACE_MAKE) -r -s $@ QUIET= V=s
-
-val.%: FORCE
+check val.% var.%: FORCE
        @+$(NO_TRACE_MAKE) -r -s $@ QUIET= V=s
 
 WARN_PARALLEL_ERROR = $(if $(BUILD_LOG),,$(and $(filter -j,$(MAKEFLAGS)),$(findstring s,$(OPENWRT_VERBOSE))))