kernel: bump 6.1 to 6.1.50
authorJohn Audia <therealgraysky@proton.me>
Wed, 30 Aug 2023 17:45:50 +0000 (13:45 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 1 Sep 2023 19:01:08 +0000 (21:01 +0200)
Changelog: https://cdn.kernel.org/pub/linux/kernel/v6.x/ChangeLog-6.1.50

All patches automatically rebased.

Build system: x86/64
Build-tested: x86/64/AMD Cezanne, filogic/xiaomi_redmi-router-ax6000-ubootmod, ipq806x/R7800
Run-tested: x86/64/AMD Cezanne, filogic/xiaomi_redmi-router-ax6000-ubootmod, ipq806x/R7800

Signed-off-by: John Audia <therealgraysky@proton.me>
19 files changed:
include/kernel-6.1
target/linux/bcm27xx/patches-6.1/950-0084-cgroup-Disable-cgroup-memory-by-default.patch
target/linux/generic/backport-6.1/788-v6.3-net-dsa-mt7530-use-external-PCS-driver.patch
target/linux/generic/backport-6.1/790-v6.4-0002-net-dsa-mt7530-refactor-SGMII-PCS-creation.patch
target/linux/generic/backport-6.1/790-v6.4-0003-net-dsa-mt7530-use-unlocked-regmap-accessors.patch
target/linux/generic/backport-6.1/790-v6.4-0004-net-dsa-mt7530-use-regmap-to-access-switch-register-.patch
target/linux/generic/backport-6.1/790-v6.4-0005-net-dsa-mt7530-move-SGMII-PCS-creation-to-mt7530_pro.patch
target/linux/generic/backport-6.1/790-v6.4-0006-net-dsa-mt7530-introduce-mutex-helpers.patch
target/linux/generic/backport-6.1/790-v6.4-0007-net-dsa-mt7530-move-p5_intf_modes-function-to-mt7530.patch
target/linux/generic/backport-6.1/790-v6.4-0008-net-dsa-mt7530-introduce-mt7530_probe_common-helper-.patch
target/linux/generic/backport-6.1/790-v6.4-0009-net-dsa-mt7530-introduce-mt7530_remove_common-helper.patch
target/linux/generic/backport-6.1/790-v6.4-0010-net-dsa-mt7530-introduce-separate-MDIO-driver.patch
target/linux/generic/backport-6.1/790-v6.4-0012-net-dsa-mt7530-introduce-driver-for-MT7988-built-in-.patch
target/linux/generic/backport-6.1/790-v6.4-0013-net-dsa-mt7530-fix-support-for-MT7531BE.patch
target/linux/generic/hack-6.1/280-rfkill-stubs.patch
target/linux/generic/hack-6.1/902-debloat_proc.patch
target/linux/generic/pending-6.1/710-bridge-add-knob-for-filtering-rx-tx-BPDU-pack.patch
target/linux/generic/pending-6.1/723-net-mt7531-ensure-all-MACs-are-powered-down-before-r.patch
target/linux/generic/pending-6.1/795-mt7530-register-OF-node-for-internal-MDIO-bus.patch

index 8bba284fb499ee90d2e0289bcb7ed22be9ada8c6..79d9b49ad79efe01b3fa0df4c58f6e54b91e7c36 100644 (file)
@@ -1,2 +1,2 @@
-LINUX_VERSION-6.1 = .49
-LINUX_KERNEL_HASH-6.1.49 = c9ea14231ca4ca6e3882a9339a8c3c414e4c91519d3e50af6822f47e99057a0f
+LINUX_VERSION-6.1 = .50
+LINUX_KERNEL_HASH-6.1.50 = b27ac1443eea563bc546ee1f67d9802bc8d6c0f6f18707407fba01f9f78c488c
index f97882c163cda2a185c27d02ab3590f773a2088f..316c630be8f2d8ae2519057004a2f49515ed9b3e 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/kernel/cgroup/cgroup.c
 +++ b/kernel/cgroup/cgroup.c
-@@ -6060,6 +6060,9 @@ int __init cgroup_init_early(void)
+@@ -6061,6 +6061,9 @@ int __init cgroup_init_early(void)
        return 0;
  }
  
@@ -27,7 +27,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  /**
   * cgroup_init - cgroup initialization
   *
-@@ -6093,6 +6096,12 @@ int __init cgroup_init(void)
+@@ -6094,6 +6097,12 @@ int __init cgroup_init(void)
  
        cgroup_unlock();
  
@@ -40,7 +40,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        for_each_subsys(ss, ssid) {
                if (ss->early_init) {
                        struct cgroup_subsys_state *css =
-@@ -6730,6 +6739,10 @@ static int __init cgroup_disable(char *s
+@@ -6734,6 +6743,10 @@ static int __init cgroup_disable(char *s
                            strcmp(token, ss->legacy_name))
                                continue;
  
@@ -51,7 +51,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
                        static_branch_disable(cgroup_subsys_enabled_key[i]);
                        pr_info("Disabling %s control group subsystem\n",
                                ss->name);
-@@ -6748,6 +6761,31 @@ static int __init cgroup_disable(char *s
+@@ -6752,6 +6765,31 @@ static int __init cgroup_disable(char *s
  }
  __setup("cgroup_disable=", cgroup_disable);
  
index aa781dc7b68497fb41f8990d558486525425a170..8010076fc003faebaf347a48f510d326f6d12833 100644 (file)
@@ -81,7 +81,7 @@ Tested-by: Frank Wunderlich <frank-w@public-files.de>
  #include <linux/phylink.h>
  #include <linux/regmap.h>
  #include <linux/regulator/consumer.h>
-@@ -2611,128 +2612,11 @@ static int mt7531_rgmii_setup(struct mt7
+@@ -2615,128 +2616,11 @@ static int mt7531_rgmii_setup(struct mt7
        return 0;
  }
  
@@ -210,7 +210,7 @@ Tested-by: Frank Wunderlich <frank-w@public-files.de>
  static int
  mt7531_mac_config(struct dsa_switch *ds, int port, unsigned int mode,
                  phy_interface_t interface)
-@@ -2755,11 +2639,11 @@ mt7531_mac_config(struct dsa_switch *ds,
+@@ -2759,11 +2643,11 @@ mt7531_mac_config(struct dsa_switch *ds,
                phydev = dp->slave->phydev;
                return mt7531_rgmii_setup(priv, port, interface, phydev);
        case PHY_INTERFACE_MODE_SGMII:
@@ -224,7 +224,7 @@ Tested-by: Frank Wunderlich <frank-w@public-files.de>
        default:
                return -EINVAL;
        }
-@@ -2784,11 +2668,11 @@ mt753x_phylink_mac_select_pcs(struct dsa
+@@ -2788,11 +2672,11 @@ mt753x_phylink_mac_select_pcs(struct dsa
  
        switch (interface) {
        case PHY_INTERFACE_MODE_TRGMII:
@@ -238,7 +238,7 @@ Tested-by: Frank Wunderlich <frank-w@public-files.de>
        default:
                return NULL;
        }
-@@ -3029,86 +2913,6 @@ static void mt7530_pcs_get_state(struct
+@@ -3033,86 +2917,6 @@ static void mt7530_pcs_get_state(struct
                state->pause |= MLO_PAUSE_TX;
  }
  
@@ -325,7 +325,7 @@ Tested-by: Frank Wunderlich <frank-w@public-files.de>
  static int mt753x_pcs_config(struct phylink_pcs *pcs, unsigned int mode,
                             phy_interface_t interface,
                             const unsigned long *advertising,
-@@ -3128,18 +2932,57 @@ static const struct phylink_pcs_ops mt75
+@@ -3132,18 +2936,57 @@ static const struct phylink_pcs_ops mt75
        .pcs_an_restart = mt7530_pcs_an_restart,
  };
  
@@ -389,7 +389,7 @@ Tested-by: Frank Wunderlich <frank-w@public-files.de>
        int i, ret;
  
        /* Initialise the PCS devices */
-@@ -3147,8 +2990,6 @@ mt753x_setup(struct dsa_switch *ds)
+@@ -3151,8 +2994,6 @@ mt753x_setup(struct dsa_switch *ds)
                priv->pcs[i].pcs.ops = priv->info->pcs_ops;
                priv->pcs[i].priv = priv;
                priv->pcs[i].port = i;
@@ -398,7 +398,7 @@ Tested-by: Frank Wunderlich <frank-w@public-files.de>
        }
  
        ret = priv->info->sw_setup(ds);
-@@ -3163,6 +3004,16 @@ mt753x_setup(struct dsa_switch *ds)
+@@ -3167,6 +3008,16 @@ mt753x_setup(struct dsa_switch *ds)
        if (ret && priv->irq)
                mt7530_free_irq_common(priv);
  
@@ -415,7 +415,7 @@ Tested-by: Frank Wunderlich <frank-w@public-files.de>
        return ret;
  }
  
-@@ -3254,7 +3105,7 @@ static const struct mt753x_info mt753x_t
+@@ -3258,7 +3109,7 @@ static const struct mt753x_info mt753x_t
        },
        [ID_MT7531] = {
                .id = ID_MT7531,
@@ -424,7 +424,7 @@ Tested-by: Frank Wunderlich <frank-w@public-files.de>
                .sw_setup = mt7531_setup,
                .phy_read = mt7531_ind_phy_read,
                .phy_write = mt7531_ind_phy_write,
-@@ -3362,7 +3213,7 @@ static void
+@@ -3366,7 +3217,7 @@ static void
  mt7530_remove(struct mdio_device *mdiodev)
  {
        struct mt7530_priv *priv = dev_get_drvdata(&mdiodev->dev);
@@ -433,7 +433,7 @@ Tested-by: Frank Wunderlich <frank-w@public-files.de>
  
        if (!priv)
                return;
-@@ -3381,6 +3232,10 @@ mt7530_remove(struct mdio_device *mdiode
+@@ -3385,6 +3236,10 @@ mt7530_remove(struct mdio_device *mdiode
                mt7530_free_irq(priv);
  
        dsa_unregister_switch(priv->ds);
@@ -446,7 +446,7 @@ Tested-by: Frank Wunderlich <frank-w@public-files.de>
  
 --- a/drivers/net/dsa/mt7530.h
 +++ b/drivers/net/dsa/mt7530.h
-@@ -369,47 +369,8 @@ enum mt7530_vlan_port_acc_frm {
+@@ -371,47 +371,8 @@ enum mt7530_vlan_port_acc_frm {
                                         CCR_TX_OCT_CNT_BAD)
  
  /* MT7531 SGMII register group */
@@ -496,7 +496,7 @@ Tested-by: Frank Wunderlich <frank-w@public-files.de>
  
  /* Register for system reset */
  #define MT7530_SYS_CTRL                       0x7000
-@@ -708,13 +669,13 @@ struct mt7530_fdb {
+@@ -710,13 +671,13 @@ struct mt7530_fdb {
   * @pm:               The matrix used to show all connections with the port.
   * @pvid:     The VLAN specified is to be considered a PVID at ingress.  Any
   *            untagged frames will be assigned to the related VLAN.
index 0e15cce2497a3d885c0b252bd4979c8bcbc0e7fc..56674492967b53a3ac742ae3ed1f98baa2b118ad 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -2964,26 +2964,56 @@ static const struct regmap_bus mt7531_re
+@@ -2968,26 +2968,56 @@ static const struct regmap_bus mt7531_re
        .reg_update_bits = mt7530_regmap_update_bits,
  };
  
@@ -88,7 +88,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        int i, ret;
  
        /* Initialise the PCS devices */
-@@ -3005,15 +3035,11 @@ mt753x_setup(struct dsa_switch *ds)
+@@ -3009,15 +3039,11 @@ mt753x_setup(struct dsa_switch *ds)
        if (ret && priv->irq)
                mt7530_free_irq_common(priv);
  
index a40f3b8f3b9cb485071b9dae252ae87f2217b3c6..3b4689fb1947b13b5d75087486650a7375d4c022 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -2937,7 +2937,7 @@ static int mt7530_regmap_read(void *cont
+@@ -2941,7 +2941,7 @@ static int mt7530_regmap_read(void *cont
  {
        struct mt7530_priv *priv = context;
  
@@ -28,7 +28,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        return 0;
  };
  
-@@ -2945,23 +2945,25 @@ static int mt7530_regmap_write(void *con
+@@ -2949,23 +2949,25 @@ static int mt7530_regmap_write(void *con
  {
        struct mt7530_priv *priv = context;
  
@@ -62,7 +62,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  };
  
  static int
-@@ -2987,6 +2989,9 @@ mt7531_create_sgmii(struct mt7530_priv *
+@@ -2991,6 +2993,9 @@ mt7531_create_sgmii(struct mt7530_priv *
                mt7531_pcs_config[i]->reg_stride = 4;
                mt7531_pcs_config[i]->reg_base = MT7531_SGMII_REG_BASE(5 + i);
                mt7531_pcs_config[i]->max_register = 0x17c;
index ae17d17d175e5584d120693b901dc6ca555c1add..04033f14f47632c94bd629cb17055a3cce3d8dca 100644 (file)
@@ -133,7 +133,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  }
  
  static void
-@@ -2933,22 +2954,6 @@ static const struct phylink_pcs_ops mt75
+@@ -2937,22 +2958,6 @@ static const struct phylink_pcs_ops mt75
        .pcs_an_restart = mt7530_pcs_an_restart,
  };
  
@@ -156,7 +156,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  static void
  mt7530_mdio_regmap_lock(void *mdio_lock)
  {
-@@ -2961,7 +2966,7 @@ mt7530_mdio_regmap_unlock(void *mdio_loc
+@@ -2965,7 +2970,7 @@ mt7530_mdio_regmap_unlock(void *mdio_loc
        mutex_unlock(mdio_lock);
  }
  
@@ -165,7 +165,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        .reg_write = mt7530_regmap_write,
        .reg_read = mt7530_regmap_read,
  };
-@@ -2994,7 +2999,7 @@ mt7531_create_sgmii(struct mt7530_priv *
+@@ -2998,7 +3003,7 @@ mt7531_create_sgmii(struct mt7530_priv *
                mt7531_pcs_config[i]->lock_arg = &priv->bus->mdio_lock;
  
                regmap = devm_regmap_init(priv->dev,
@@ -174,7 +174,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                                          mt7531_pcs_config[i]);
                if (IS_ERR(regmap)) {
                        ret = PTR_ERR(regmap);
-@@ -3159,6 +3164,7 @@ MODULE_DEVICE_TABLE(of, mt7530_of_match)
+@@ -3163,6 +3168,7 @@ MODULE_DEVICE_TABLE(of, mt7530_of_match)
  static int
  mt7530_probe(struct mdio_device *mdiodev)
  {
@@ -182,7 +182,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        struct mt7530_priv *priv;
        struct device_node *dn;
  
-@@ -3238,6 +3244,21 @@ mt7530_probe(struct mdio_device *mdiodev
+@@ -3242,6 +3248,21 @@ mt7530_probe(struct mdio_device *mdiodev
        mutex_init(&priv->reg_mutex);
        dev_set_drvdata(&mdiodev->dev, priv);
  
@@ -206,7 +206,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
 --- a/drivers/net/dsa/mt7530.h
 +++ b/drivers/net/dsa/mt7530.h
-@@ -752,6 +752,7 @@ struct mt753x_info {
+@@ -754,6 +754,7 @@ struct mt753x_info {
   * @dev:              The device pointer
   * @ds:                       The pointer to the dsa core structure
   * @bus:              The bus used for the device and built-in PHY
@@ -214,7 +214,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
   * @rstc:             The pointer to reset control used by MCM
   * @core_pwr:         The power supplied into the core
   * @io_pwr:           The power supplied into the I/O
-@@ -772,6 +773,7 @@ struct mt7530_priv {
+@@ -774,6 +775,7 @@ struct mt7530_priv {
        struct device           *dev;
        struct dsa_switch       *ds;
        struct mii_bus          *bus;
index bbee3d22da20ab02127810190c33e3cd1eb20ec7..6c5bebdd8024df71497780443949d9c07a5f4e05 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -3045,12 +3045,6 @@ mt753x_setup(struct dsa_switch *ds)
+@@ -3049,12 +3049,6 @@ mt753x_setup(struct dsa_switch *ds)
        if (ret && priv->irq)
                mt7530_free_irq_common(priv);
  
@@ -31,7 +31,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        return ret;
  }
  
-@@ -3167,6 +3161,7 @@ mt7530_probe(struct mdio_device *mdiodev
+@@ -3171,6 +3165,7 @@ mt7530_probe(struct mdio_device *mdiodev
        static struct regmap_config *regmap_config;
        struct mt7530_priv *priv;
        struct device_node *dn;
@@ -39,7 +39,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
        dn = mdiodev->dev.of_node;
  
-@@ -3259,6 +3254,12 @@ mt7530_probe(struct mdio_device *mdiodev
+@@ -3263,6 +3258,12 @@ mt7530_probe(struct mdio_device *mdiodev
        if (IS_ERR(priv->regmap))
                return PTR_ERR(priv->regmap);
  
index 13de0a12f2f06dc951f4f49fc20626dfbf0338fd..a8933d2cf4e9a23a0ecdd26a367120251848a340 100644 (file)
@@ -214,7 +214,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
        return ret;
  }
-@@ -1121,7 +1121,6 @@ static int
+@@ -1125,7 +1125,6 @@ static int
  mt7530_port_change_mtu(struct dsa_switch *ds, int port, int new_mtu)
  {
        struct mt7530_priv *priv = ds->priv;
@@ -222,7 +222,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        int length;
        u32 val;
  
-@@ -1132,7 +1131,7 @@ mt7530_port_change_mtu(struct dsa_switch
+@@ -1136,7 +1135,7 @@ mt7530_port_change_mtu(struct dsa_switch
        if (!dsa_is_cpu_port(ds, port))
                return 0;
  
@@ -231,7 +231,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
        val = mt7530_mii_read(priv, MT7530_GMACCR);
        val &= ~MAX_RX_PKT_LEN_MASK;
-@@ -1153,7 +1152,7 @@ mt7530_port_change_mtu(struct dsa_switch
+@@ -1157,7 +1156,7 @@ mt7530_port_change_mtu(struct dsa_switch
  
        mt7530_mii_write(priv, MT7530_GMACCR, val);
  
@@ -240,7 +240,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
        return 0;
  }
-@@ -1954,10 +1953,10 @@ mt7530_irq_thread_fn(int irq, void *dev_
+@@ -1958,10 +1957,10 @@ mt7530_irq_thread_fn(int irq, void *dev_
        u32 val;
        int p;
  
@@ -253,7 +253,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
        for (p = 0; p < MT7530_NUM_PHYS; p++) {
                if (BIT(p) & val) {
-@@ -1993,7 +1992,7 @@ mt7530_irq_bus_lock(struct irq_data *d)
+@@ -1997,7 +1996,7 @@ mt7530_irq_bus_lock(struct irq_data *d)
  {
        struct mt7530_priv *priv = irq_data_get_irq_chip_data(d);
  
@@ -262,7 +262,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  }
  
  static void
-@@ -2002,7 +2001,7 @@ mt7530_irq_bus_sync_unlock(struct irq_da
+@@ -2006,7 +2005,7 @@ mt7530_irq_bus_sync_unlock(struct irq_da
        struct mt7530_priv *priv = irq_data_get_irq_chip_data(d);
  
        mt7530_mii_write(priv, MT7530_SYS_INT_EN, priv->irq_enable);
index f46f753b218c18282b126441e2342bdb06cbea22..6c68dc0c4fd3d378e52710d4ee429f4519338047 100644 (file)
@@ -48,7 +48,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        struct mt7530_priv *priv = ds->priv;
 --- a/drivers/net/dsa/mt7530.h
 +++ b/drivers/net/dsa/mt7530.h
-@@ -687,24 +687,6 @@ enum p5_interface_select {
+@@ -689,24 +689,6 @@ enum p5_interface_select {
        P5_INTF_SEL_GMAC5_SGMII,
  };
  
index 89f39a93852dfe76ce06f3ce506901c5081b3938..dc4fcb6aa11fdcdc91976ecf701639c80df099f4 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -3173,44 +3173,21 @@ static const struct of_device_id mt7530_
+@@ -3177,44 +3177,21 @@ static const struct of_device_id mt7530_
  MODULE_DEVICE_TABLE(of, mt7530_of_match);
  
  static int
@@ -67,7 +67,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        if (!priv->info)
                return -EINVAL;
  
-@@ -3224,23 +3201,53 @@ mt7530_probe(struct mdio_device *mdiodev
+@@ -3228,23 +3205,53 @@ mt7530_probe(struct mdio_device *mdiodev
                return -EINVAL;
  
        priv->id = priv->info->id;
@@ -131,7 +131,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                priv->reset = devm_gpiod_get_optional(&mdiodev->dev, "reset",
                                                      GPIOD_OUT_LOW);
                if (IS_ERR(priv->reset)) {
-@@ -3249,12 +3256,15 @@ mt7530_probe(struct mdio_device *mdiodev
+@@ -3253,12 +3260,15 @@ mt7530_probe(struct mdio_device *mdiodev
                }
        }
  
index 654d9a88ebf216079263c6a03fb20aaf2eb500d7..5df859d2dff26ca8ebf6be7f2f6d4464b58f96f2 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -3291,6 +3291,17 @@ mt7530_probe(struct mdio_device *mdiodev
+@@ -3295,6 +3295,17 @@ mt7530_probe(struct mdio_device *mdiodev
  }
  
  static void
@@ -35,7 +35,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  mt7530_remove(struct mdio_device *mdiodev)
  {
        struct mt7530_priv *priv = dev_get_drvdata(&mdiodev->dev);
-@@ -3309,15 +3320,10 @@ mt7530_remove(struct mdio_device *mdiode
+@@ -3313,15 +3324,10 @@ mt7530_remove(struct mdio_device *mdiode
                dev_err(priv->dev, "Failed to disable io pwr: %d\n",
                        ret);
  
index 219a96731a650fa4c9ab848efaec7e38a85526f3..b75710ba572da2dee8f99ae6442781bf7d5cad84 100644 (file)
@@ -416,7 +416,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  static u32
  mt7530_mii_read(struct mt7530_priv *priv, u32 reg)
  {
-@@ -2971,72 +2922,6 @@ static const struct phylink_pcs_ops mt75
+@@ -2975,72 +2926,6 @@ static const struct phylink_pcs_ops mt75
        .pcs_an_restart = mt7530_pcs_an_restart,
  };
  
@@ -489,7 +489,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  static int
  mt753x_setup(struct dsa_switch *ds)
  {
-@@ -3095,7 +2980,7 @@ static int mt753x_set_mac_eee(struct dsa
+@@ -3099,7 +2984,7 @@ static int mt753x_set_mac_eee(struct dsa
        return 0;
  }
  
@@ -498,7 +498,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        .get_tag_protocol       = mtk_get_tag_protocol,
        .setup                  = mt753x_setup,
        .get_strings            = mt7530_get_strings,
-@@ -3129,8 +3014,9 @@ static const struct dsa_switch_ops mt753
+@@ -3133,8 +3018,9 @@ static const struct dsa_switch_ops mt753
        .get_mac_eee            = mt753x_get_mac_eee,
        .set_mac_eee            = mt753x_set_mac_eee,
  };
@@ -509,7 +509,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        [ID_MT7621] = {
                .id = ID_MT7621,
                .pcs_ops = &mt7530_pcs_ops,
-@@ -3163,16 +3049,9 @@ static const struct mt753x_info mt753x_t
+@@ -3167,16 +3053,9 @@ static const struct mt753x_info mt753x_t
                .mac_port_config = mt7531_mac_config,
        },
  };
@@ -528,7 +528,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  mt7530_probe_common(struct mt7530_priv *priv)
  {
        struct device *dev = priv->dev;
-@@ -3209,88 +3088,9 @@ mt7530_probe_common(struct mt7530_priv *
+@@ -3213,88 +3092,9 @@ mt7530_probe_common(struct mt7530_priv *
  
        return 0;
  }
@@ -619,7 +619,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  mt7530_remove_common(struct mt7530_priv *priv)
  {
        if (priv->irq)
-@@ -3300,55 +3100,7 @@ mt7530_remove_common(struct mt7530_priv
+@@ -3304,55 +3104,7 @@ mt7530_remove_common(struct mt7530_priv
  
        mutex_destroy(&priv->reg_mutex);
  }
@@ -678,7 +678,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  MODULE_DESCRIPTION("Driver for Mediatek MT7530 Switch");
 --- a/drivers/net/dsa/mt7530.h
 +++ b/drivers/net/dsa/mt7530.h
-@@ -812,4 +812,10 @@ static inline void INIT_MT7530_DUMMY_POL
+@@ -814,4 +814,10 @@ static inline void INIT_MT7530_DUMMY_POL
        p->reg = reg;
  }
  
index abe6bbb04c48a982a4c62a5f94a1aa4880cbed12..934af995cd16c12898d2967313c8b6f4c8c84358 100644 (file)
@@ -184,7 +184,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 +MODULE_LICENSE("GPL");
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -2001,6 +2001,47 @@ static const struct irq_domain_ops mt753
+@@ -2005,6 +2005,47 @@ static const struct irq_domain_ops mt753
  };
  
  static void
@@ -232,7 +232,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  mt7530_setup_mdio_irq(struct mt7530_priv *priv)
  {
        struct dsa_switch *ds = priv->ds;
-@@ -2034,8 +2075,15 @@ mt7530_setup_irq(struct mt7530_priv *pri
+@@ -2038,8 +2079,15 @@ mt7530_setup_irq(struct mt7530_priv *pri
                return priv->irq ? : -EINVAL;
        }
  
@@ -250,7 +250,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        if (!priv->irq_domain) {
                dev_err(dev, "failed to create IRQ domain\n");
                return -ENOMEM;
-@@ -2534,6 +2582,25 @@ static void mt7531_mac_port_get_caps(str
+@@ -2538,6 +2586,25 @@ static void mt7531_mac_port_get_caps(str
        }
  }
  
@@ -276,7 +276,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  static int
  mt753x_pad_setup(struct dsa_switch *ds, const struct phylink_link_state *state)
  {
-@@ -2610,6 +2677,17 @@ static bool mt753x_is_mac_port(u32 port)
+@@ -2614,6 +2681,17 @@ static bool mt753x_is_mac_port(u32 port)
  }
  
  static int
@@ -294,7 +294,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  mt7531_mac_config(struct dsa_switch *ds, int port, unsigned int mode,
                  phy_interface_t interface)
  {
-@@ -2679,7 +2757,8 @@ mt753x_phylink_mac_config(struct dsa_swi
+@@ -2683,7 +2761,8 @@ mt753x_phylink_mac_config(struct dsa_swi
  
        switch (port) {
        case 0 ... 4: /* Internal phy */
@@ -304,7 +304,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                        goto unsupported;
                break;
        case 5: /* 2nd cpu port with phy of port 0 or 4 / external phy */
-@@ -2757,7 +2836,8 @@ static void mt753x_phylink_mac_link_up(s
+@@ -2761,7 +2840,8 @@ static void mt753x_phylink_mac_link_up(s
        /* MT753x MAC works in 1G full duplex mode for all up-clocked
         * variants.
         */
@@ -314,7 +314,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
            (phy_interface_mode_is_8023z(interface))) {
                speed = SPEED_1000;
                duplex = DUPLEX_FULL;
-@@ -2837,6 +2917,21 @@ mt7531_cpu_port_config(struct dsa_switch
+@@ -2841,6 +2921,21 @@ mt7531_cpu_port_config(struct dsa_switch
        return 0;
  }
  
@@ -336,7 +336,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  static void mt753x_phylink_get_caps(struct dsa_switch *ds, int port,
                                    struct phylink_config *config)
  {
-@@ -2982,6 +3077,27 @@ static int mt753x_set_mac_eee(struct dsa
+@@ -2986,6 +3081,27 @@ static int mt753x_set_mac_eee(struct dsa
        return 0;
  }
  
@@ -364,7 +364,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  const struct dsa_switch_ops mt7530_switch_ops = {
        .get_tag_protocol       = mtk_get_tag_protocol,
        .setup                  = mt753x_setup,
-@@ -3050,6 +3166,17 @@ const struct mt753x_info mt753x_table[]
+@@ -3054,6 +3170,17 @@ const struct mt753x_info mt753x_table[]
                .mac_port_get_caps = mt7531_mac_port_get_caps,
                .mac_port_config = mt7531_mac_config,
        },
@@ -407,7 +407,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                                         MT7531_MIRROR_MASK : MIRROR_MASK)
  
  /* Registers for BPDU and PAE frame control*/
-@@ -300,9 +301,8 @@ enum mt7530_vlan_port_acc_frm {
+@@ -302,9 +303,8 @@ enum mt7530_vlan_port_acc_frm {
                                         MT7531_FORCE_DPX | \
                                         MT7531_FORCE_RX_FC | \
                                         MT7531_FORCE_TX_FC)
index 4e127f197094b45e7ef6b8474ecca5ef32443287..5b5f25e7afaf10434b9b18d104b538ff0e76c7bd 100644 (file)
@@ -73,7 +73,7 @@ Signed-off-by: Jakub Kicinski <kuba@kernel.org>
  }
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -3044,6 +3044,12 @@ mt753x_setup(struct dsa_switch *ds)
+@@ -3048,6 +3048,12 @@ mt753x_setup(struct dsa_switch *ds)
        if (ret && priv->irq)
                mt7530_free_irq_common(priv);
  
@@ -88,7 +88,7 @@ Signed-off-by: Jakub Kicinski <kuba@kernel.org>
  
 --- a/drivers/net/dsa/mt7530.h
 +++ b/drivers/net/dsa/mt7530.h
-@@ -746,10 +746,10 @@ struct mt753x_info {
+@@ -748,10 +748,10 @@ struct mt753x_info {
   *                    registers
   * @p6_interface      Holding the current port 6 interface
   * @p5_intf_sel:      Holding the current port 5 interface select
@@ -100,7 +100,7 @@ Signed-off-by: Jakub Kicinski <kuba@kernel.org>
   */
  struct mt7530_priv {
        struct device           *dev;
-@@ -768,7 +768,6 @@ struct mt7530_priv {
+@@ -770,7 +770,6 @@ struct mt7530_priv {
        unsigned int            p5_intf_sel;
        u8                      mirror_rx;
        u8                      mirror_tx;
@@ -108,7 +108,7 @@ Signed-off-by: Jakub Kicinski <kuba@kernel.org>
        struct mt7530_port      ports[MT7530_NUM_PORTS];
        struct mt753x_pcs       pcs[MT7530_NUM_PORTS];
        /* protect among processes for registers access*/
-@@ -776,6 +775,7 @@ struct mt7530_priv {
+@@ -778,6 +777,7 @@ struct mt7530_priv {
        int irq;
        struct irq_domain *irq_domain;
        u32 irq_enable;
index ff6638f7a05b4c62090d365fab8c3d06c23ed35e..7a650d132eb3aec49136b735b30651b371d85f4b 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
   * @name: name of the struct -- the string is not copied internally
 --- a/net/Makefile
 +++ b/net/Makefile
-@@ -51,7 +51,7 @@ obj-$(CONFIG_TIPC)           += tipc/
+@@ -52,7 +52,7 @@ obj-$(CONFIG_TIPC)           += tipc/
  obj-$(CONFIG_NETLABEL)                += netlabel/
  obj-$(CONFIG_IUCV)            += iucv/
  obj-$(CONFIG_SMC)             += smc/
index 1b7b72f44df4d2f5a15f1c9c1ad36d49d1581d58..abf588f12fc372e8a055343abed95e991769affb 100644 (file)
@@ -235,7 +235,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!pe)
 --- a/mm/vmalloc.c
 +++ b/mm/vmalloc.c
-@@ -4183,6 +4183,8 @@ static const struct seq_operations vmall
+@@ -4187,6 +4187,8 @@ static const struct seq_operations vmall
  
  static int __init proc_vmalloc_init(void)
  {
index 4c09ed6b50d57b72617bee81447b34f563860df2..989aca8f3537bf244566e33d32eb01c0ea332d53 100644 (file)
@@ -161,7 +161,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  struct rtnl_link {
        rtnl_doit_func          doit;
-@@ -4823,7 +4823,9 @@ int ndo_dflt_bridge_getlink(struct sk_bu
+@@ -4840,7 +4840,9 @@ int ndo_dflt_bridge_getlink(struct sk_bu
            brport_nla_put_flag(skb, flags, mask,
                                IFLA_BRPORT_MCAST_FLOOD, BR_MCAST_FLOOD) ||
            brport_nla_put_flag(skb, flags, mask,
index 6540819d47a5692f0293397e0456b17aa27dc31c..a18d1ad7173fe0a73dce3ef5109a5d1f5eea4f3f 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
 
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -2248,6 +2248,10 @@ mt7530_setup(struct dsa_switch *ds)
+@@ -2252,6 +2252,10 @@ mt7530_setup(struct dsa_switch *ds)
                return -ENODEV;
        }
  
index d4e0d4107b504af75089fd5a45ee6dc01ed8a955..d333f3f4890da963db983541e014182a57d6b567 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -2138,10 +2138,13 @@ mt7530_setup_mdio(struct mt7530_priv *pr
+@@ -2142,10 +2142,13 @@ mt7530_setup_mdio(struct mt7530_priv *pr
  {
        struct dsa_switch *ds = priv->ds;
        struct device *dev = priv->dev;
@@ -30,7 +30,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
        bus = devm_mdiobus_alloc(dev);
        if (!bus)
                return -ENOMEM;
-@@ -2158,7 +2161,9 @@ mt7530_setup_mdio(struct mt7530_priv *pr
+@@ -2162,7 +2165,9 @@ mt7530_setup_mdio(struct mt7530_priv *pr
        if (priv->irq)
                mt7530_setup_mdio_irq(priv);