trusted-firmware-a.mk: use correct CPE ID
authorStijn Tintel <stijn@linux-ipv6.be>
Tue, 20 Dec 2022 18:04:53 +0000 (20:04 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Tue, 20 Dec 2022 18:36:26 +0000 (18:36 +0000)
There are 2 different CPE IDs on the NVD website:
cpe:/a:arm:trusted_firmware-a
cpe:/o:arm:arm_trusted_firmware

The ID as currently used in trusted-firmware-a.mk does not exist. The
CPE ID using the arm_trusted_firmware product name only lists a few
records for versions 2.2 and 2.3 on the NVD site. The CPE ID using the
trusted_firmware-a product name lists many more records, and actually
has a CVE linked to it. Therefore, use the CPE ID using the
trusted_firmware-a product name.

Fixes: 104d60fe94ce ("trusted-firmware-a.mk: add PKG_CPE_ID")
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
include/trusted-firmware-a.mk

index 0b37c0f94382599c4e6ed7a207ca435dfef5eb4a..082ada269c895bf7a95a68b06c3db33162d58d0e 100644 (file)
@@ -1,5 +1,5 @@
 PKG_NAME ?= trusted-firmware-a
-PKG_CPE_ID ?= cpe:/a:arm:arm_trusted_firmware
+PKG_CPE_ID ?= cpe:/a:arm:trusted_firmware-a
 
 ifndef PKG_SOURCE_PROTO
 PKG_SOURCE = trusted-firmware-a-$(PKG_VERSION).tar.gz