libmnl: fix build when bash is not located at /bin/bash
authorMark Mentovai <mark@mentovai.com>
Sun, 10 Jul 2022 23:43:05 +0000 (19:43 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 31 Jul 2022 18:30:20 +0000 (20:30 +0200)
This fixes the libmnl build on macOS, which ships with an outdated bash
at /bin/bash. During the OpenWrt build, a modern host bash is built and
made available at staging_dir/host/bin/bash, which is present before
/bin/bash in the build's PATH.

This is similar to 8f7ce3aa6dda, presently appearing at
package/kernel/mac80211/patches/build/001-fix_build.patch.

Signed-off-by: Mark Mentovai <mark@mentovai.com>
package/libs/libmnl/patches/001-fix_build.patch [new file with mode: 0644]

diff --git a/package/libs/libmnl/patches/001-fix_build.patch b/package/libs/libmnl/patches/001-fix_build.patch
new file mode 100644 (file)
index 0000000..d095ec8
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/doxygen/Makefile.am
++++ b/doxygen/Makefile.am
+@@ -21,7 +21,7 @@ doxyfile.stamp: $(doc_srcs) Makefile.am
+ # The command has to be a single line so the functions work
+ # and so `make` gives all lines to `bash -c`
+ # (hence ";\" at the end of every line but the last).
+-      /bin/bash -p -c 'declare -A renamed_page;\
++      bash -p -c 'declare -A renamed_page;\
+ main(){ set -e; cd man/man3; rm -f _*;\
+   count_real_pages;\
+   rename_real_pages;\