quilt.mk: use CURDIR instead of ./ for PATCH_DIR and FILES_DIR
authorChristian Marangi <ansuelsmth@gmail.com>
Mon, 25 Sep 2023 00:26:43 +0000 (02:26 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Fri, 6 Oct 2023 19:59:28 +0000 (21:59 +0200)
To better reference them for diagnostic use, reference the PATCH_DIR and
FILES_DIR with the absolute path instead of using ./ and reference by
the relative location.

No behaviour change intended.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
include/quilt.mk

index 18cafe60a280bb1fccce96bb9bfff9954d284cb5..140d3905283f5a40b96b3e50ab24d7ca4797126c 100644 (file)
@@ -34,8 +34,8 @@ endif
 ifneq ($(if $(DUMP),1,$(__quilt_inc)),1)
 __quilt_inc:=1
 
-PATCH_DIR?=./patches
-FILES_DIR?=./files
+PATCH_DIR?=$(CURDIR)/patches
+FILES_DIR?=$(CURDIR)/files
 HOST_PATCH_DIR?=$(PATCH_DIR)
 HOST_FILES_DIR?=$(FILES_DIR)