mpc85xx: kernel: 6.6: refresh patches
authorPawel Dembicki <paweldembicki@gmail.com>
Wed, 13 Mar 2024 10:01:01 +0000 (11:01 +0100)
committerRobert Marko <robimarko@gmail.com>
Sun, 24 Mar 2024 20:20:46 +0000 (21:20 +0100)
Manualy refreshed:
101-powerpc-85xx-hiveap-330-support.patch
105-powerpc-85xx-panda-support.patch

Rest done by 'make target/linux/refresh'

Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
12 files changed:
target/linux/mpc85xx/patches-6.6/001-powerpc-85xx-add-gpio-keys-to-of-match-table.patch
target/linux/mpc85xx/patches-6.6/100-powerpc-85xx-tl-wdr4900-v1-support.patch
target/linux/mpc85xx/patches-6.6/101-powerpc-85xx-hiveap-330-support.patch
target/linux/mpc85xx/patches-6.6/102-powerpc-add-cmdline-override.patch
target/linux/mpc85xx/patches-6.6/103-powerpc-85xx-red-15w-rev1.patch
target/linux/mpc85xx/patches-6.6/105-powerpc-85xx-panda-support.patch
target/linux/mpc85xx/patches-6.6/106-powerpc-85xx-ws-ap3710i-support.patch
target/linux/mpc85xx/patches-6.6/107-powerpc-85xx-add-ws-ap3825i-support.patch
target/linux/mpc85xx/patches-6.6/108-powerpc-85xx-firebox-t10-support.patch.patch
target/linux/mpc85xx/patches-6.6/109-powerpc-85xx-add-ws-ap3715i-support.patch
target/linux/mpc85xx/patches-6.6/110-powerpc-85xx-br200-wp-support.patch
target/linux/mpc85xx/patches-6.6/900-powerpc-bootwrapper-disable-uImage-generation.patch

index 5e5ab10daf1d02096404701d5b56ef894ed3ad98..42ab234d90d8014fc8fa41d804a3fc2676882f49 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/powerpc/platforms/85xx/common.c
 +++ b/arch/powerpc/platforms/85xx/common.c
-@@ -30,6 +30,7 @@ static const struct of_device_id mpc85xx
+@@ -31,6 +31,7 @@ static const struct of_device_id mpc85xx
        { .compatible = "fsl,mpc8548-guts", },
        /* Probably unnecessary? */
        { .compatible = "gpio-leds", },
index a7253a97946e6e46299fa9cb78749fd4727dad55..800341c6e11b3e6ab41dde3dcf15fc34ff2078df 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
 
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -179,6 +179,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
+@@ -181,6 +181,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
  src-plat-$(CONFIG_PPC_POWERNV) += pseries-head.S
  src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
  src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
@@ -27,7 +27,7 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
  
  src-plat-$(CONFIG_PPC_MICROWATT) += fixed-head.S microwatt.c
  
-@@ -359,7 +360,7 @@ image-$(CONFIG_TQM8548)                    += cuImage.tqm
+@@ -351,7 +352,7 @@ image-$(CONFIG_TQM8548)                    += cuImage.tqm
  image-$(CONFIG_TQM8555)                       += cuImage.tqm8555
  image-$(CONFIG_TQM8560)                       += cuImage.tqm8560
  image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
@@ -38,7 +38,7 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
  
 --- a/arch/powerpc/boot/wrapper
 +++ b/arch/powerpc/boot/wrapper
-@@ -341,6 +341,11 @@ adder875-redboot)
+@@ -345,6 +345,11 @@ adder875-redboot)
      platformo="$object/fixed-head.o $object/redboot-8xx.o"
      binary=y
      ;;
@@ -52,7 +52,7 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
      binary=y
 --- a/arch/powerpc/platforms/85xx/Kconfig
 +++ b/arch/powerpc/platforms/85xx/Kconfig
-@@ -163,6 +163,18 @@ config STX_GP3
+@@ -176,6 +176,18 @@ config STX_GP3
        select CPM2
        select DEFAULT_UIMAGE
  
@@ -73,7 +73,7 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
        help
 --- a/arch/powerpc/platforms/85xx/Makefile
 +++ b/arch/powerpc/platforms/85xx/Makefile
-@@ -27,6 +27,7 @@ obj-$(CONFIG_TWR_P102x)   += twr_p102x.o
+@@ -26,6 +26,7 @@ obj-$(CONFIG_TWR_P102x)   += twr_p102x.o
  obj-$(CONFIG_CORENET_GENERIC)   += corenet_generic.o
  obj-$(CONFIG_FB_FSL_DIU)      += t1042rdb_diu.o
  obj-$(CONFIG_STX_GP3)   += stx_gp3.o
index e8b6632f2b052ef502fdffec9e0adc43e22f9024..952df5e8a6b15e73a5df23404746edf949e834ec 100644 (file)
  obj-$(CONFIG_BSC9132_QDS) += bsc913x_qds.o
  obj-$(CONFIG_C293_PCIE)   += c293pcie.o
 +obj-$(CONFIG_HIVEAP_330) += hiveap-330.o
- obj-$(CONFIG_MPC8540_ADS) += mpc85xx_ads.o
- obj-$(CONFIG_MPC8560_ADS) += mpc85xx_ads.o
- obj-$(CONFIG_MPC85xx_CDS) += mpc85xx_cds.o
+ obj-$(CONFIG_MPC8536_DS)  += mpc8536_ds.o
+ obj8259-$(CONFIG_PPC_I8259)   += mpc85xx_8259.o
+ obj-$(CONFIG_MPC85xx_DS)  += mpc85xx_ds.o $(obj8259-y)
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -179,6 +179,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
+@@ -181,6 +181,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
  src-plat-$(CONFIG_PPC_POWERNV) += pseries-head.S
  src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
  src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
@@ -38,7 +38,7 @@
  src-plat-$(CONFIG_TL_WDR4900_V1) += simpleboot.c fixed-head.S
  
  src-plat-$(CONFIG_PPC_MICROWATT) += fixed-head.S microwatt.c
-@@ -360,6 +361,7 @@ image-$(CONFIG_TQM8548)                    += cuImage.tqm
+@@ -352,6 +353,7 @@ image-$(CONFIG_TQM8548)                    += cuImage.tqm
  image-$(CONFIG_TQM8555)                       += cuImage.tqm8555
  image-$(CONFIG_TQM8560)                       += cuImage.tqm8560
  image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
@@ -48,7 +48,7 @@
  image-$(CONFIG_MVME7100)                += dtbImage.mvme7100
 --- a/arch/powerpc/boot/wrapper
 +++ b/arch/powerpc/boot/wrapper
-@@ -341,6 +341,7 @@ adder875-redboot)
+@@ -345,6 +345,7 @@ adder875-redboot)
      platformo="$object/fixed-head.o $object/redboot-8xx.o"
      binary=y
      ;;
index b83e5f86d2e7013f6dc89f4b86841a10299a7e05..17aee6dafe6c6c3b4b6ae59004d234ad6e45a42e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/powerpc/Kconfig
 +++ b/arch/powerpc/Kconfig
-@@ -954,6 +954,14 @@ config CMDLINE_FORCE
+@@ -1005,6 +1005,14 @@ config CMDLINE_FORCE
  
  endchoice
  
@@ -17,7 +17,7 @@
        help
 --- a/drivers/of/fdt.c
 +++ b/drivers/of/fdt.c
-@@ -1187,6 +1187,17 @@ int __init early_init_dt_scan_chosen(cha
+@@ -1189,6 +1189,17 @@ int __init early_init_dt_scan_chosen(cha
        if (p != NULL && l > 0)
                strlcat(cmdline, p, min_t(int, strlen(cmdline) + (int)l, COMMAND_LINE_SIZE));
  
index 711d98abe750347df0fe921dc51be6d589d15715..551f306e562eaa803c756d5d114a30821c4d5574 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/powerpc/platforms/85xx/Kconfig
 +++ b/arch/powerpc/platforms/85xx/Kconfig
-@@ -166,6 +166,16 @@ config XES_MPC85xx
+@@ -179,6 +179,16 @@ config XES_MPC85xx
          Manufacturer: Extreme Engineering Solutions, Inc.
          URL: <https://www.xes-inc.com/>
  
@@ -19,7 +19,7 @@
        help
 --- a/arch/powerpc/platforms/85xx/Makefile
 +++ b/arch/powerpc/platforms/85xx/Makefile
-@@ -27,6 +27,7 @@ obj-$(CONFIG_P1023_RDB)   += p1023_rdb.o
+@@ -26,6 +26,7 @@ obj-$(CONFIG_PPC_P2020)   += p2020.o $(o
  obj-$(CONFIG_TWR_P102x)   += twr_p102x.o
  obj-$(CONFIG_CORENET_GENERIC)   += corenet_generic.o
  obj-$(CONFIG_FB_FSL_DIU)      += t1042rdb_diu.o
index 3c24a373aba759948cefec979c6d8fb89fc583db..e463c495399461137d53889fcaad60f37d61b90c 100644 (file)
        select DEFAULT_UIMAGE
 --- a/arch/powerpc/platforms/85xx/Makefile
 +++ b/arch/powerpc/platforms/85xx/Makefile
-@@ -24,6 +24,7 @@ obj-$(CONFIG_P1010_RDB)   += p1010rdb.o
+@@ -22,6 +22,7 @@ obj-$(CONFIG_P1010_RDB)   += p1010rdb.o
  obj-$(CONFIG_P1022_DS)    += p1022_ds.o
  obj-$(CONFIG_P1022_RDK)   += p1022_rdk.o
  obj-$(CONFIG_P1023_RDB)   += p1023_rdb.o
 +obj-$(CONFIG_PANDA)       += panda.o
+ obj-$(CONFIG_PPC_P2020)   += p2020.o $(obj8259-y)
  obj-$(CONFIG_TWR_P102x)   += twr_p102x.o
  obj-$(CONFIG_CORENET_GENERIC)   += corenet_generic.o
- obj-$(CONFIG_FB_FSL_DIU)      += t1042rdb_diu.o
index 5ac3f2f2d9419df6a1f702d1db4fc050e7ae4a6e..469b696833041d232610cae08bc35f28e339e27d 100644 (file)
@@ -20,9 +20,9 @@
        select DEFAULT_UIMAGE
 --- a/arch/powerpc/platforms/85xx/Makefile
 +++ b/arch/powerpc/platforms/85xx/Makefile
-@@ -26,6 +26,7 @@ obj-$(CONFIG_P1022_RDK)   += p1022_rdk.o
- obj-$(CONFIG_P1023_RDB)   += p1023_rdb.o
+@@ -25,6 +25,7 @@ obj-$(CONFIG_P1023_RDB)   += p1023_rdb.o
  obj-$(CONFIG_PANDA)       += panda.o
+ obj-$(CONFIG_PPC_P2020)   += p2020.o $(obj8259-y)
  obj-$(CONFIG_TWR_P102x)   += twr_p102x.o
 +obj-$(CONFIG_WS_AP3710I)  += ws-ap3710i.o
  obj-$(CONFIG_CORENET_GENERIC)   += corenet_generic.o
index 63e7e46bbc5f00de7c6aaf9dc6509a3f8c25c9ce..8a42064570c076ee1351204cf63f188c28cb8d7b 100644 (file)
@@ -27,8 +27,8 @@ WS-AP3825i AP.
        select DEFAULT_UIMAGE
 --- a/arch/powerpc/platforms/85xx/Makefile
 +++ b/arch/powerpc/platforms/85xx/Makefile
-@@ -27,6 +27,7 @@ obj-$(CONFIG_P1023_RDB)   += p1023_rdb.o
- obj-$(CONFIG_PANDA)       += panda.o
+@@ -26,6 +26,7 @@ obj-$(CONFIG_PANDA)       += panda.o
+ obj-$(CONFIG_PPC_P2020)   += p2020.o $(obj8259-y)
  obj-$(CONFIG_TWR_P102x)   += twr_p102x.o
  obj-$(CONFIG_WS_AP3710I)  += ws-ap3710i.o
 +obj-$(CONFIG_WS_AP3825I)  += ws-ap3825i.o
@@ -37,7 +37,7 @@ WS-AP3825i AP.
  obj-$(CONFIG_RED_15W_REV1)    += red15w_rev1.o
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -181,6 +181,7 @@ src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) +=
+@@ -183,6 +183,7 @@ src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) +=
  src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
  src-plat-$(CONFIG_HIVEAP_330) += simpleboot.c fixed-head.S
  src-plat-$(CONFIG_TL_WDR4900_V1) += simpleboot.c fixed-head.S
@@ -45,7 +45,7 @@ WS-AP3825i AP.
  
  src-plat-$(CONFIG_PPC_MICROWATT) += fixed-head.S microwatt.c
  
-@@ -363,6 +364,7 @@ image-$(CONFIG_TQM8560)                    += cuImage.tqm
+@@ -355,6 +356,7 @@ image-$(CONFIG_TQM8560)                    += cuImage.tqm
  image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
  image-$(CONFIG_HIVEAP_330)            += simpleImage.hiveap-330
  image-$(CONFIG_TL_WDR4900_V1)         += simpleImage.tl-wdr4900-v1
@@ -55,7 +55,7 @@ WS-AP3825i AP.
  
 --- a/arch/powerpc/boot/wrapper
 +++ b/arch/powerpc/boot/wrapper
-@@ -342,6 +342,7 @@ adder875-redboot)
+@@ -346,6 +346,7 @@ adder875-redboot)
      binary=y
      ;;
  simpleboot-hiveap-330|\
index 0b3a93b8486adcbccf0a928f62460db0f83282f8..2c722e4d9bf78852d5aa83eb9dd162486e769155 100644 (file)
@@ -19,7 +19,7 @@
        select DEFAULT_UIMAGE
 --- a/arch/powerpc/platforms/85xx/Makefile
 +++ b/arch/powerpc/platforms/85xx/Makefile
-@@ -28,6 +28,7 @@ obj-$(CONFIG_PANDA)       += panda.o
+@@ -27,6 +27,7 @@ obj-$(CONFIG_PPC_P2020)   += p2020.o $(o
  obj-$(CONFIG_TWR_P102x)   += twr_p102x.o
  obj-$(CONFIG_WS_AP3710I)  += ws-ap3710i.o
  obj-$(CONFIG_WS_AP3825I)  += ws-ap3825i.o
index f8e33ae63791c798775a70b2d0e379c8ffdaa480..d6c59e8f72c00b18197a96a0a35bc5bd4d6aa486 100644 (file)
@@ -20,8 +20,8 @@
        select DEFAULT_UIMAGE
 --- a/arch/powerpc/platforms/85xx/Makefile
 +++ b/arch/powerpc/platforms/85xx/Makefile
-@@ -27,6 +27,7 @@ obj-$(CONFIG_P1023_RDB)   += p1023_rdb.o
- obj-$(CONFIG_PANDA)       += panda.o
+@@ -26,6 +26,7 @@ obj-$(CONFIG_PANDA)       += panda.o
+ obj-$(CONFIG_PPC_P2020)   += p2020.o $(obj8259-y)
  obj-$(CONFIG_TWR_P102x)   += twr_p102x.o
  obj-$(CONFIG_WS_AP3710I)  += ws-ap3710i.o
 +obj-$(CONFIG_WS_AP3715I)  += ws-ap3715i.o
@@ -30,7 +30,7 @@
  obj-$(CONFIG_CORENET_GENERIC)   += corenet_generic.o
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -364,6 +364,7 @@ image-$(CONFIG_TQM8560)                    += cuImage.tqm
+@@ -356,6 +356,7 @@ image-$(CONFIG_TQM8560)                    += cuImage.tqm
  image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
  image-$(CONFIG_HIVEAP_330)            += simpleImage.hiveap-330
  image-$(CONFIG_TL_WDR4900_V1)         += simpleImage.tl-wdr4900-v1
@@ -40,7 +40,7 @@
  image-$(CONFIG_MVME7100)                += dtbImage.mvme7100
 --- a/arch/powerpc/boot/wrapper
 +++ b/arch/powerpc/boot/wrapper
-@@ -342,6 +342,7 @@ adder875-redboot)
+@@ -346,6 +346,7 @@ adder875-redboot)
      binary=y
      ;;
  simpleboot-hiveap-330|\
index b063b3dab742f4c547ccaa48209f79df421cf3d0..f3ec26ec99fb36a3380e008c5eb35d6e2d96385d 100644 (file)
  obj-$(CONFIG_C293_PCIE)   += c293pcie.o
 +obj-$(CONFIG_BR200_WP) += br200-wp.o
  obj-$(CONFIG_HIVEAP_330) += hiveap-330.o
- obj-$(CONFIG_MPC8540_ADS) += mpc85xx_ads.o
- obj-$(CONFIG_MPC8560_ADS) += mpc85xx_ads.o
+ obj-$(CONFIG_MPC8536_DS)  += mpc8536_ds.o
+ obj8259-$(CONFIG_PPC_I8259)   += mpc85xx_8259.o
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -179,6 +179,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
+@@ -181,6 +181,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
  src-plat-$(CONFIG_PPC_POWERNV) += pseries-head.S
  src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
  src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
@@ -37,7 +37,7 @@
  src-plat-$(CONFIG_HIVEAP_330) += simpleboot.c fixed-head.S
  src-plat-$(CONFIG_TL_WDR4900_V1) += simpleboot.c fixed-head.S
  src-plat-$(CONFIG_WS_AP3825I) += simpleboot.c fixed-head.S
-@@ -362,6 +363,7 @@ image-$(CONFIG_TQM8548)                    += cuImage.tqm
+@@ -354,6 +355,7 @@ image-$(CONFIG_TQM8548)                    += cuImage.tqm
  image-$(CONFIG_TQM8555)                       += cuImage.tqm8555
  image-$(CONFIG_TQM8560)                       += cuImage.tqm8560
  image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
@@ -47,7 +47,7 @@
  image-$(CONFIG_WS_AP3715I)            += simpleImage.ws-ap3715i
 --- a/arch/powerpc/boot/wrapper
 +++ b/arch/powerpc/boot/wrapper
-@@ -341,6 +341,7 @@ adder875-redboot)
+@@ -345,6 +345,7 @@ adder875-redboot)
      platformo="$object/fixed-head.o $object/redboot-8xx.o"
      binary=y
      ;;
index 648aa0421d68f7f6a2191dc761283b753c5ae361..d5bef0338767ba7b9bcf2a74d3ed8dd4fb35f407 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -291,7 +291,6 @@ image-$(CONFIG_PPC_CHRP)           += zImage.chrp
+@@ -293,7 +293,6 @@ image-$(CONFIG_PPC_CHRP)           += zImage.chrp
  image-$(CONFIG_PPC_EFIKA)             += zImage.chrp
  image-$(CONFIG_PPC_PMAC)              += zImage.pmac
  image-$(CONFIG_PPC_HOLLY)             += dtbImage.holly
@@ -24,7 +24,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
  image-$(CONFIG_EPAPR_BOOT)            += zImage.epapr
  
  #
-@@ -427,15 +426,6 @@ $(obj)/dtbImage.%: vmlinux $(wrapperbits
+@@ -418,15 +417,6 @@ $(obj)/dtbImage.%: vmlinux $(wrapperbits
  $(obj)/vmlinux.strip: vmlinux
        $(STRIP) -s -R .comment $< -o $@