hwmon: add TC654 fan-controller support
authorZoltan HERPAI <wigyori@uid0.hu>
Tue, 5 Mar 2024 12:22:11 +0000 (13:22 +0100)
committerZoltan HERPAI <wigyori@uid0.hu>
Sat, 16 Mar 2024 23:19:20 +0000 (00:19 +0100)
Add support for the Microchip TC654 PWM fan-controller.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
package/kernel/linux/modules/hwmon.mk

index 5be63ce7793a4b6e90f45577ff2c7c1bc3f08350..be38a6071a7b7aac6d5a63f8238e049cec5e456d 100644 (file)
@@ -572,6 +572,21 @@ endef
 $(eval $(call KernelPackage,hwmon-sht3x))
 
 
+define KernelPackage/hwmon-tc654
+  TITLE:=TC654 monitoring support
+  KCONFIG:=CONFIG_SENSORS_TC654
+  FILES:=$(LINUX_DIR)/drivers/hwmon/tc654.ko
+  AUTOLOAD:=$(call AutoLoad,60,tc654)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-tc654/description
+ Kernel module for Microchip TC654/TC655 and compatibles
+endef
+
+$(eval $(call KernelPackage,hwmon-tc654))
+
+
 define KernelPackage/hwmon-tmp102
   TITLE:=Texas Instruments TMP102 monitoring support
   KCONFIG:=CONFIG_SENSORS_TMP102