octeon: add uboot-envtools to snic10e device packages
authorStijn Tintel <stijn@linux-ipv6.be>
Sun, 14 Nov 2021 18:34:35 +0000 (20:34 +0200)
committerStijn Tintel <stijn@linux-ipv6.be>
Thu, 9 Nov 2023 12:35:03 +0000 (14:35 +0200)
And include a uci-defaults file to configure /etc/fw_env.config.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
target/linux/octeon/base-files/etc/board.d/30_uboot-envtools [new file with mode: 0644]
target/linux/octeon/image/Makefile

diff --git a/target/linux/octeon/base-files/etc/board.d/30_uboot-envtools b/target/linux/octeon/base-files/etc/board.d/30_uboot-envtools
new file mode 100644 (file)
index 0000000..b3ee1fe
--- /dev/null
@@ -0,0 +1,11 @@
+. /lib/functions.sh
+
+board=$(board_name)
+
+case "$board" in
+snic10e)
+       printf "/dev/mtd2\t0x0\t0x2000\t0x2000\n" > /etc/fw_env.config
+       ;;
+esac
+
+exit 0
index 1ca2d5eb16240af0e571756b709fcebaeed21ed7..74e31b859d07c4acbda956efcf517ddee16bffca 100644 (file)
@@ -78,7 +78,7 @@ define Device/snic10e
   DEVICE_VENDOR := Cavium
   DEVICE_MODEL := snic10e
   DEVICE_DTS := snic10e
-  DEVICE_PACKAGES += kmod-gpio-button-hotplug kmod-hwmon-tmp421 kmod-leds-gpio kmod-of-mdio kmod-sfp
+  DEVICE_PACKAGES += kmod-gpio-button-hotplug kmod-hwmon-tmp421 kmod-leds-gpio kmod-of-mdio kmod-sfp uboot-envtools
   KERNEL := kernel-bin | append-dtb-to-elf
   KERNEL_DEPENDS := $$(wildcard $(DTS_DIR)/$(DEVICE_DTS).dts)
 endef