ath79: image: add supported string for routerstations and ja76pf2
authorTomasz Maciej Nowak <tomek_n@o2.pl>
Fri, 23 Aug 2019 13:50:50 +0000 (15:50 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 31 Aug 2019 22:12:02 +0000 (00:12 +0200)
Now that the md5 check is fixed and metadata present, sysupgrade on
ar71xx will complain about device not being supported by the image.
Since the cause is not matching strings for supported devices add them
accordingly.

Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
target/linux/ath79/image/generic-ubnt.mk
target/linux/ath79/image/generic.mk

index 3af1f2676eb0fe809bd88e773b8f5ba569166d63..c696aac3a825f8722c55a2365004b21d74d1df1c 100644 (file)
@@ -223,6 +223,7 @@ define Device/ubnt_routerstation
   UBNT_TYPE := RSx
   UBNT_CHIP := ar7100
   DEVICE_PACKAGES += -swconfig
+  SUPPORTED_DEVICES += routerstation
 endef
 TARGET_DEVICES += ubnt_routerstation
 
@@ -232,6 +233,7 @@ define Device/ubnt_routerstation-pro
   UBNT_BOARD := RSPRO
   UBNT_TYPE := RSPRO
   UBNT_CHIP := ar7100pro
+  SUPPORTED_DEVICES += routerstation-pro
 endef
 TARGET_DEVICES += ubnt_routerstation-pro
 
index 941e007a4776f8d2a518119f23832cf6d9db7b50..718e060994168832faa7f77b6a51121e67484c9b 100644 (file)
@@ -658,6 +658,7 @@ define Device/jjplus_ja76pf2
   KERNEL := kernel-bin | append-dtb | lzma | pad-to $$(BLOCKSIZE)
   KERNEL_INITRAMFS := kernel-bin | append-dtb
   IMAGE_SIZE := 16000k
+  SUPPORTED_DEVICES += ja76pf2
 endef
 TARGET_DEVICES += jjplus_ja76pf2