qca-nss-dp: cp instead of symlink for `nss_dp_arch.h`
authorSean Khan <datapronix@protonmail.com>
Mon, 1 Apr 2024 02:03:22 +0000 (22:03 -0400)
committerRobert Marko <robimarko@gmail.com>
Mon, 1 Apr 2024 17:44:45 +0000 (19:44 +0200)
Build files shouldn't be symlinked into the staging directory, as doing so
would create a race condition if the build folder for 'qca-nss-dp' gets
deleted for any reason.

We should instead just copy over the required platform file to avoid
breaking compilation for any dependent packages.

Signed-off-by: Sean Khan <datapronix@protonmail.com>
package/kernel/qca-nss-dp/Makefile

index e17446d23634c45f2734ab33f40df84eed0cd7be..167a9af4e4c385f3589b95ba4bd0f3efd7c84909 100644 (file)
@@ -39,7 +39,7 @@ EXTRA_CFLAGS+= \
 
 NSS_DP_HAL_DIR:=$(PKG_BUILD_DIR)/hal
 define Build/Configure
-       $(LN) $(NSS_DP_HAL_DIR)/soc_ops/$(CONFIG_TARGET_SUBTARGET)/nss_$(CONFIG_TARGET_SUBTARGET).h \
+       $(CP) $(NSS_DP_HAL_DIR)/soc_ops/$(CONFIG_TARGET_SUBTARGET)/nss_$(CONFIG_TARGET_SUBTARGET).h \
                $(PKG_BUILD_DIR)/exports/nss_dp_arch.h
 endef