ramips: add mt7615e support to Netgear R6350
authorChristoph Krapp <achterin@googlemail.com>
Thu, 29 Aug 2019 08:06:12 +0000 (10:06 +0200)
committerDavid Bauer <mail@david-bauer.net>
Sat, 31 Aug 2019 08:31:00 +0000 (10:31 +0200)
Signed-off-by: Christoph Krapp <achterin@googlemail.com>
target/linux/ramips/dts/mt7621_netgear_r6350.dts
target/linux/ramips/image/mt7621.mk

index a5c3a1907cbcbc2c9893e9a0ff836443dd6313ea..54640244c52ff7047d120788a6eb623449597521 100644 (file)
        status = "okay";
 };
 
+&pcie0 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+       };
+};
+
 &pcie1 {
        wifi@0,0 {
                reg = <0x0 0 0 0 0>;
index a00e6280c7259520ac11afe6e75b3fd6a2815873..3b79c509f3e7fb6479d7d0d3fbe443efa56e4226 100644 (file)
@@ -428,7 +428,7 @@ define Device/netgear_r6350
   DEVICE_VENDOR := NETGEAR
   DEVICE_MODEL := R6350
   DEVICE_PACKAGES := \
-       kmod-mt7603 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+       kmod-mt7603 kmod-mt7615e kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
 endef
 TARGET_DEVICES += netgear_r6350