tools/mpfr: Update to 4.0.2
authorDaniel Engberg <daniel.engberg.lists@pyret.net>
Sun, 10 Feb 2019 11:32:19 +0000 (11:32 +0000)
committerHans Dedecker <dedeckeh@gmail.com>
Sun, 10 Feb 2019 19:51:09 +0000 (20:51 +0100)
Update mpfr to 4.0.2
Use official site as last resort
Force thread-safety functionality
Refresh patches

Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
tools/mpfr/Makefile
tools/mpfr/patches/100-freebsd-compat.patch

index dfff7964ce4830c8d5837171d70832f55a6ed5f4..fdb316efb961984f5f92aa9439e8827a1929f2f9 100644 (file)
@@ -7,13 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpfr
-PKG_VERSION:=4.0.1
+PKG_VERSION:=4.0.2
 PKG_CPE_ID:=cpe:/a:mpfr:gnu_mpfr
 
-PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-$(PKG_VERSION) \
-               @GNU/mpfr
+PKG_SOURCE_URL:=@GNU/mpfr http://www.mpfr.org/mpfr-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_HASH:=67874a60826303ee2fb6affc6dc0ddd3e749e9bfcb4c8655e3953d0458a6e16e
+PKG_HASH:=1d3be708604eae0e42d578ba93b390c2a145f17743a744d8f3f8c2ad5855a38a
 
 HOST_BUILD_PARALLEL:=1
 HOST_FIXUP:=autoreconf
@@ -23,6 +22,7 @@ include $(INCLUDE_DIR)/host-build.mk
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared \
+       --enable-thread-safe \
        --with-gmp=$(STAGING_DIR_HOST)
 
 $(eval $(call HostBuild))
index c357b68736f660bb6f9535de84baa525846d9603..8a7c6b098e2f53fe7bda16bcc28e751d2898d26f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/vasprintf.c
 +++ b/src/vasprintf.c
-@@ -61,6 +61,7 @@ http://www.gnu.org/licenses/ or write to
+@@ -72,6 +72,7 @@ https://www.gnu.org/licenses/ or write t
  #endif /* HAVE_VA_COPY */
  
  #ifdef HAVE_WCHAR_H