ath79: image: retire combined-image for Adtran/Bluesocket devices
authorTomasz Maciej Nowak <tomek_n@o2.pl>
Fri, 23 Aug 2019 13:50:47 +0000 (15:50 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 31 Aug 2019 22:12:02 +0000 (00:12 +0200)
During review it slipped by that these devices use combined-image which
should never be used for newly added ones. Therefore switch to
sysupgrade-tar generated images introduced in 8f6f260 ("ath79:
routerstation: prepare to use sysupgrade-tar format image"). The
sysupgrade accepts both images for now so no reression should occur.

Cc: Brian Gonyer <bgonyer@gmail.com>
Cc: Daniel Gimpelevich <daniel@gimpelevich.san-francisco.ca.us>
Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
target/linux/ath79/image/generic.mk

index eed0e2b683700ba1ea8bc767380aa469e57d7d5f..fe80be980cc53c133d4995818ad54607b357aa54 100644 (file)
@@ -108,7 +108,7 @@ define Device/adtran_bsap1880
   IMAGES += kernel.bin rootfs.bin
   IMAGE/kernel.bin := append-kernel | pad-to $$$$(BLOCKSIZE)
   IMAGE/rootfs.bin := append-rootfs | pad-rootfs
-  IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | combined-image | append-metadata | check-size $$$$(IMAGE_SIZE)
+  IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | sysupgrade-tar rootfs=$$$$@ | append-metadata
 endef
 
 define Device/adtran_bsap1800-v2