linux-firmware: package Intel AX201 firmware
authorPetr Štetiar <ynezz@true.cz>
Mon, 4 Mar 2024 07:16:19 +0000 (07:16 +0000)
committerRobert Marko <robimarko@gmail.com>
Sun, 24 Mar 2024 20:12:13 +0000 (21:12 +0100)
Alexander reported following:

 iwlwifi 0000:00:14.3: Detected crf-id 0x3617, cnv-id 0x20000302 wfpm id 0x80000000
 iwlwifi 0000:00:14.3: PCI dev a0f0/0074, rev=0x351, rfid=0x10a100
 iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-QuZ-a0-hr-b0-77.ucode failed with error -2

It seems, that as of the current date, the highest firmware API version
supported by Linux 6.8-rc7 is still 77.

Closes: #14771
Signed-off-by: Petr Štetiar <ynezz@true.cz>
package/firmware/linux-firmware/intel.mk

index 0719e2b28c3864c5e812891f5a6c71d334a0a4b9..f6acb45d4817f5b6a6fcd58c7175bc24d7289056 100644 (file)
@@ -184,6 +184,13 @@ define Package/iwlwifi-firmware-ax200/install
 endef
 $(eval $(call BuildPackage,iwlwifi-firmware-ax200))
 
+Package/iwlwifi-firmware-ax201 = $(call Package/firmware-default,Intel AX201 firmware)
+define Package/iwlwifi-firmware-ax201/install
+       $(INSTALL_DIR) $(1)/lib/firmware
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/iwlwifi-QuZ-a0-hr-b0-77.ucode $(1)/lib/firmware
+endef
+$(eval $(call BuildPackage,iwlwifi-firmware-ax201))
+
 Package/iwlwifi-firmware-ax210 = $(call Package/firmware-default,Intel AX210 firmware)
 define Package/iwlwifi-firmware-ax210/install
        $(INSTALL_DIR) $(1)/lib/firmware