ipq40xx: compress kernel for Magic 2 WiFi next
authorThomas Bong <thomas.bong@devolo.de>
Thu, 31 Aug 2023 08:43:15 +0000 (10:43 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 3 Sep 2023 21:11:51 +0000 (23:11 +0200)
The bootcmd limits the kernel to 4 MiB which is
exceeded when using Device/FitImage. Device/FitzImage
reduces the size to around 3 MiB.

Reviewed-by: Robert Marko <robimarko@gmail.com>
Signed-off-by: Thomas Bong <thomas.bong@devolo.de>
target/linux/ipq40xx/image/generic.mk

index 58836471f0c63f67416983a30bbf15d18be332ef..15f48a67b255cbfa399b9e0bc8798d2dbcbc54df 100644 (file)
@@ -371,7 +371,7 @@ endef
 TARGET_DEVICES += compex_wpj428
 
 define Device/devolo_magic-2-wifi-next
-       $(call Device/FitImage)
+       $(call Device/FitzImage)
        DEVICE_VENDOR := devolo
        DEVICE_MODEL := Magic 2 WiFi next
        SOC := qcom-ipq4018
@@ -387,7 +387,6 @@ define Device/devolo_magic-2-wifi-next
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
        DEFAULT := n
 endef
-# Missing DSA Setup
 TARGET_DEVICES += devolo_magic-2-wifi-next
 
 define Device/dlink_dap-2610