xdp-tools: mark as nonshared
authorNick Hainke <vincent@systemli.org>
Tue, 5 Jul 2022 07:21:04 +0000 (09:21 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 6 Jul 2022 21:38:02 +0000 (22:38 +0100)
The SDK does not have the LLVM toolchain yet.

Hopefully fixes errors in the form:
  xsk_def_xdp_prog.c:4:10: fatal error: 'bpf/bpf_helpers.h' file not found
  #include <bpf/bpf_helpers.h>

Fixes: 6ad1bea2a603 ("xdp-tools: add package")
Signed-off-by: Nick Hainke <vincent@systemli.org>
package/network/utils/xdp-tools/Makefile

index 3b93a13163a40c08c00f942ca881fe017fa8d111..f0af555919d8db3f37107d26cd6b9ab5869032d4 100644 (file)
@@ -12,6 +12,7 @@ PKG_ABI_VERSION:=$(call abi_version_str,$(PKG_VERSION))
 PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
 
 PKG_BUILD_DEPENDS:=bpf-headers
+PKG_FLAGS:=nonshared
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/bpf.mk