mediatek: fix build failure of mt7623/mt7629 using kernel 6.6
authorWeijie Gao <hackpascal@gmail.com>
Fri, 15 Mar 2024 15:13:55 +0000 (23:13 +0800)
committerChuanhong Guo <gch981213@gmail.com>
Sat, 16 Mar 2024 07:25:05 +0000 (15:25 +0800)
In kernel 6.6, dts files for mediatek arm target are moved into
arch/arm/boot/dts/mediatek instead of legacy path arch/arm/boot/dts.

To avoid dts compile failure, change DTS_DIR to the mediatek subfolder
for kernel 6.6.

Signed-off-by: Weijie Gao <hackpascal@gmail.com>
target/linux/mediatek/image/mt7623.mk
target/linux/mediatek/image/mt7629.mk

index 24663551e0f7cb9a859003ae9540aca6f6690583..93625c405b96d820425913982af81dd9afd73490 100644 (file)
@@ -1,3 +1,7 @@
+ifneq ($(KERNEL),6.1)
+DTS_DIR := $(DTS_DIR)/mediatek
+endif
+
 DEVICE_VARS += UBOOT_TARGET UBOOT_OFFSET UBOOT_IMAGE
 
 # The bootrom of MT7623 expects legacy MediaTek headers present in
index 9374228808c8f8a5e8f9ea048c11f13c73ad57cc..9f0ea98950f2ac9755e0f026c7534e5759b54e79 100644 (file)
@@ -1,3 +1,7 @@
+ifneq ($(KERNEL),6.1)
+DTS_DIR := $(DTS_DIR)/mediatek
+endif
+
 define Device/mediatek_mt7629-rfb
   DEVICE_VENDOR := MediaTek
   DEVICE_MODEL := MT7629 rfb AP