prereq-build: add Python 3.12 support
authorRosen Penev <rosenp@gmail.com>
Thu, 9 Nov 2023 18:53:02 +0000 (10:53 -0800)
committerPaul Spooren <mail@aparcar.org>
Sun, 12 Nov 2023 11:15:55 +0000 (12:15 +0100)
Fixes build on Fedora 39.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
include/prereq-build.mk

index 49340ce3e441ccbaa1833d6eb38d8abd450f627e..2378f5ad90c961472f8751f2d116f9978d976b7d 100644 (file)
@@ -182,6 +182,7 @@ $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
        perl --version | grep "perl.*v5"))
 
 $(eval $(call SetupHostCommand,python,Please install Python >= 3.7, \
+       python3.12 -V 2>&1 | grep 'Python 3', \
        python3.11 -V 2>&1 | grep 'Python 3', \
        python3.10 -V 2>&1 | grep 'Python 3', \
        python3.9 -V 2>&1 | grep 'Python 3', \
@@ -190,6 +191,7 @@ $(eval $(call SetupHostCommand,python,Please install Python >= 3.7, \
        python3 -V 2>&1 | grep -E 'Python 3\.([7-9]|[0-9][0-9])\.?'))
 
 $(eval $(call SetupHostCommand,python3,Please install Python >= 3.7, \
+       python3.12 -V 2>&1 | grep 'Python 3', \
        python3.11 -V 2>&1 | grep 'Python 3', \
        python3.10 -V 2>&1 | grep 'Python 3', \
        python3.9 -V 2>&1 | grep 'Python 3', \