prereq: SetupHostCommand: fix wrong check result
authorPetr Štetiar <ynezz@true.cz>
Tue, 23 May 2023 12:17:47 +0000 (14:17 +0200)
committerPetr Štetiar <ynezz@true.cz>
Tue, 23 May 2023 15:49:57 +0000 (17:49 +0200)
Tony has reported, that CI tools job is failing for him in macOS
container due to prereq check failure for GNU `install` utility.

Michael diagnosed it and from his traces it was clear, that the issue is
caused by a wrong return value in the success check case, so lets fix it
accordingly.

Fixes: f75204036ccc ("prereq-build: allow host command symlinks to update")
Reported-by: Tony Ambardar <itugrok@yahoo.com>
Diagnosed-by: Michael Pratt <mcpratt@pm.me>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/prereq.mk

index 5646b24efaa61a1f8b2c066901f192ea65508730..74c3914d060da3566caccb34f3aa7682050ed5ba 100644 (file)
@@ -113,7 +113,7 @@ define SetupHostCommand
                                                ;; \
                                esac; \
                                ln -sf "$$$$$$$$bin" "$(STAGING_DIR_HOST)/bin/$(strip $(1))"; \
-                               exit 1; \
+                               exit 0; \
                        fi; \
                fi; \
        done; \