packages: store URL in Manifest
authorPaul Spooren <mail@aparcar.org>
Sat, 6 Jan 2024 17:48:46 +0000 (18:48 +0100)
committerPaul Spooren <mail@aparcar.org>
Mon, 8 Jan 2024 13:06:38 +0000 (14:06 +0100)
The manifest should provide as much information as possible about the
package, including the project URL. With this commit the URL is stored
as it's own attribute instead of at the end of the description.

Signed-off-by: Paul Spooren <mail@aparcar.org>
include/package-dumpinfo.mk
include/package-ipkg.mk
scripts/metadata.pm

index 6baf10225de888489bd9bf1d24bf84b082cc3c84..fc25099ad30e92a6405c4f3044966f1216363aa9 100644 (file)
@@ -37,14 +37,14 @@ $(if $(USERID),Require-User: $(USERID)
 $(if $(LICENSE),License: $(LICENSE)
 )$(if $(LICENSE_FILES),LicenseFiles: $(LICENSE_FILES)
 )$(if $(PKG_CPE_ID),CPE-ID: $(PKG_CPE_ID)
+)$(if $(URL),URL: $(URL)
 )$(if $(ABI_VERSION),ABI-Version: $(ABI_VERSION)
 )Type: $(if $(Package/$(1)/targets),$(Package/$(1)/targets),$(if $(PKG_TARGETS),$(PKG_TARGETS),ipkg))
 $(if $(KCONFIG),Kernel-Config: $(KCONFIG)
 )$(if $(BUILDONLY),Build-Only: $(BUILDONLY)
 )$(if $(HIDDEN),Hidden: $(HIDDEN)
 )Description: $(if $(Package/$(1)/description),$(Package/$(1)/description),$(TITLE))
-$(if $(URL),$(URL)
-)$(MAINTAINER)
+$(MAINTAINER)
 @@
 $(if $(Package/$(1)/config),Config:
 $(Package/$(1)/config)
index afa2b81eb998007c579c0daf7a11ef00f9948438..5f5f7e13175d10f31b05e19e8d919cf6f72660a2 100644 (file)
@@ -185,6 +185,7 @@ $$(call addfield,Depends,$$(Package/$(1)/DEPENDS)
 )$$(call addfield,Section,$(SECTION)
 )$$(call addfield,Require-User,$(USERID)
 )$$(call addfield,SourceDateEpoch,$(PKG_SOURCE_DATE_EPOCH)
+)$$(call addfield,URL,$(URL)
 )$$(if $$(ABIV_$(1)),ABIVersion: $$(ABIV_$(1))
 )$(if $(PKG_CPE_ID),CPE-ID: $(PKG_CPE_ID)
 )$(if $(filter hold,$(PKG_FLAGS)),Status: unknown hold not-installed
index 587ce7207d2e6941155782be905b9a5f395358f3..ecfe42c0bc926c9a9322301fade7c73892e5e332 100644 (file)
@@ -257,6 +257,7 @@ sub parse_package_metadata($) {
                /^License: \s*(.+)\s*$/ and $pkg->{license} = $1;
                /^LicenseFiles: \s*(.+)\s*$/ and $pkg->{licensefiles} = $1;
                /^CPE-ID: \s*(.+)\s*$/ and $pkg->{cpe_id} = $1;
+               /^URL: \s*(.+)\s*$/ and $pkg->{url} = $1;
                /^ABI-Version: \s*(.+)\s*$/ and $pkg->{abi_version} = $1;
                /^Default: \s*(.+)\s*$/ and $pkg->{default} = $1;
                /^Provides: \s*(.+)\s*$/ and do {
@@ -344,6 +345,7 @@ sub parse_package_manifest_metadata($) {
                /^Section:\s*(.+)\s*$/ and $pkg->{section} = $1;
                /^SourceDateEpoch: \s*(.+)\s*$/ and $pkg->{sourcedateepoch} = $1;
                /^CPE-ID:\s*(.+)\s*$/ and $pkg->{cpe_id} = $1;
+               /^URL:\s*(.+)\s*$/ and $pkg->{url} = $1;
                /^Architecture:\s*(.+)\s*$/ and $pkg->{architecture} = $1;
                /^Installed-Size:\s*(.+)\s*$/ and $pkg->{installedsize} = $1;
                /^Filename:\s*(.+)\s*$/ and $pkg->{filename} = $1;