realtek: add Zyxel GS1900-8 v2
authorGoetz Goerisch <ggoerisch@gmail.com>
Sun, 24 Mar 2024 17:31:06 +0000 (18:31 +0100)
committerSander Vanheule <sander@svanheule.net>
Mon, 25 Mar 2024 20:28:44 +0000 (21:28 +0100)
The Zyxel GS1900-8 v2 or Rev.B1 is a newer variant of the GS1900-8, but
otherwise similar to the other GS1900 switches.

Differences
------------
* Front Button labeled RESTORE
* NO Power Switch on rear
* Serial Header next to the barrel power connector
* Part Number ends 0102F

Signed-off-by: Goetz Goerisch <ggoerisch@gmail.com>
target/linux/realtek/dts-5.15/rtl8380_zyxel_gs1900-8.dts
target/linux/realtek/image/rtl838x.mk

index e9c5efe603920f6ae82f2b6c761fde1c9b8af227..7aa1cc274cb454582d5c4a3b22919438f4c8f142 100644 (file)
@@ -4,7 +4,7 @@
 
 / {
        compatible = "zyxel,gs1900-8", "realtek,rtl838x-soc";
-       model = "ZyXEL GS1900-8 Switch";
+       model = "ZyXEL GS1900-8v1/v2 Switch";
 };
 
 &gpio1 {
index 19a40f1f61ba386ade3ec7709b8694762b9170be..dc4ddc6d1d0acb31a7afdf8c99d5a19b247d8f17 100644 (file)
@@ -313,6 +313,10 @@ define Device/zyxel_gs1900-8
   $(Device/zyxel_gs1900)
   SOC := rtl8380
   DEVICE_MODEL := GS1900-8
+  DEVICE_VARIANT := v1
+  DEVICE_ALT0_VENDOR := ZyXEL
+  DEVICE_ALT0_MODEL := GS1900-8
+  DEVICE_ALT0_VARIANT := v2
   ZYXEL_VERS := AAHH
 endef
 TARGET_DEVICES += zyxel_gs1900-8