Revert "build: don't drop 'user' flag when using the ImageBuilder"
authorDaniel Golle <daniel@makrotopia.org>
Thu, 22 Feb 2024 19:13:34 +0000 (19:13 +0000)
committerChristian Marangi <ansuelsmth@gmail.com>
Fri, 23 Feb 2024 14:59:09 +0000 (15:59 +0100)
This reverts commit c42b915af0ea53bc1b65bc72afc9875da08b14d2.
Now that rpcd uses the 'Auto-Installed' field to differentiate between
deliberately and implicitely installed packages we can remove the
hotfix.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
include/rootfs.mk

index b07f33d2046aa42fab5bd98535e845f42cdb1706..2128aefc2abda82d6f36bf7278a580ddb3922655 100644 (file)
@@ -87,11 +87,11 @@ define prepare_rootfs
                        fi; \
                done || true \
        )
-       $(if $(IB),,awk -i inplace \
+       awk -i inplace \
                '/^Status:/ { \
                        if ($$3 == "user") { $$3 = "ok" } \
                        else { sub(/,\<user\>|\<user\>,/, "", $$3) } \
-               }1' $(1)/usr/lib/opkg/status)
+               }1' $(1)/usr/lib/opkg/status
        $(if $(SOURCE_DATE_EPOCH),sed -i "s/Installed-Time: .*/Installed-Time: $(SOURCE_DATE_EPOCH)/" $(1)/usr/lib/opkg/status)
        @-find $(1) -name CVS -o -name .svn -o -name .git -o -name '.#*' | $(XARGS) rm -rf
        rm -rf \