package-dumpinfo,metadata: add ABI version information to package index
authorPetr Štetiar <ynezz@true.cz>
Thu, 26 Oct 2023 16:11:47 +0000 (16:11 +0000)
committerPetr Štetiar <ynezz@true.cz>
Wed, 1 Nov 2023 11:14:40 +0000 (11:14 +0000)
There is no standard for ABI versioning, so its not possible to find out
from `libext2fs2`, `libiwinfo20230701` or `libss2` package names if
thats just package name or package name with ABI version included. To
help with the decision, lets make ABI version aviable in package index.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/package-dumpinfo.mk
scripts/metadata.pm

index afc325c1ed66e838b57219be5ae476335b8ae58f..6baf10225de888489bd9bf1d24bf84b082cc3c84 100644 (file)
@@ -37,6 +37,7 @@ $(if $(USERID),Require-User: $(USERID)
 $(if $(LICENSE),License: $(LICENSE)
 )$(if $(LICENSE_FILES),LicenseFiles: $(LICENSE_FILES)
 )$(if $(PKG_CPE_ID),CPE-ID: $(PKG_CPE_ID)
+)$(if $(ABI_VERSION),ABI-Version: $(ABI_VERSION)
 )Type: $(if $(Package/$(1)/targets),$(Package/$(1)/targets),$(if $(PKG_TARGETS),$(PKG_TARGETS),ipkg))
 $(if $(KCONFIG),Kernel-Config: $(KCONFIG)
 )$(if $(BUILDONLY),Build-Only: $(BUILDONLY)
index e716f75d10221425a81625d3bb5f90d07e7a047b..a00d19f185a2bc28dea179e935572b19d3e04335 100644 (file)
@@ -257,6 +257,7 @@ sub parse_package_metadata($) {
                /^License: \s*(.+)\s*$/ and $pkg->{license} = $1;
                /^LicenseFiles: \s*(.+)\s*$/ and $pkg->{licensefiles} = $1;
                /^CPE-ID: \s*(.+)\s*$/ and $pkg->{cpe_id} = $1;
+               /^ABI-Version: \s*(.+)\s*$/ and $pkg->{abi_version} = $1;
                /^Default: \s*(.+)\s*$/ and $pkg->{default} = $1;
                /^Provides: \s*(.+)\s*$/ and do {
                        my @vpkg = split /\s+/, $1;