kernel: modules: video: drm: remove DRM_EXEC and DRM_SUBALLOC_HELPER
authorRobert Marko <robimarko@gmail.com>
Fri, 15 Mar 2024 10:34:20 +0000 (11:34 +0100)
committerRobert Marko <robimarko@gmail.com>
Fri, 15 Mar 2024 14:25:03 +0000 (15:25 +0100)
As part of adding kernel 6.6 support, DRM_EXEC and DRM_SUBALLOC_HELPER were
added to the kmod-drm, however these are only used by drm-amdgpu and
drm-radeon which are only supported on x86.

So, lets start fixing building of other targets by removing these from the
main kmod-drm, in follow-up commits they will be packaged separately and
selected when required.

Fixes: 5b08b5600720 ("kernel: modules: video: adapt for kernel 6.6")
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/kernel/linux/modules/video.mk

index 45034ba3e85d001ba86484bf1758ee00f981ebdf..1a4bf8ac77994cd9e33b0e1b858f1e7833bb4d82 100644 (file)
@@ -246,15 +246,11 @@ define KernelPackage/drm
   HIDDEN:=1
   DEPENDS:=+kmod-dma-buf +kmod-i2c-core +PACKAGE_kmod-backlight:kmod-backlight \
        +kmod-fb
-  KCONFIG:=CONFIG_DRM \
-       CONFIG_DRM_EXEC@ge6.6 \
-       CONFIG_DRM_SUBALLOC_HELPER@ge6.4
+  KCONFIG:=CONFIG_DRM
   FILES:= \
        $(LINUX_DIR)/drivers/gpu/drm/drm.ko \
-       $(LINUX_DIR)/drivers/gpu/drm/drm_panel_orientation_quirks.ko \
-       $(LINUX_DIR)/drivers/gpu/drm/drm_exec.ko@ge6.6 \
-       $(LINUX_DIR)/drivers/gpu/drm/drm_suballoc_helper.ko@ge6.4
-  AUTOLOAD:=$(call AutoLoad,05,drm_exec@ge6.6 drm_suballoc_helper@ge6.4 drm)
+       $(LINUX_DIR)/drivers/gpu/drm/drm_panel_orientation_quirks.ko
+  AUTOLOAD:=$(call AutoLoad,05,drm)
 endef
 
 define KernelPackage/drm/description