linux-firmware: add LICENSE_FILES and LICENSE file handling
authorFlorian Eckert <fe@dev.tdt.de>
Wed, 13 Mar 2024 12:21:34 +0000 (13:21 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 29 Mar 2024 12:11:47 +0000 (13:11 +0100)
The firmware blobs have all different licenses from the different
manufacturers of the binary blobs. This information is contained in the
upstream 'linux-firmware' repositroy.

This commit extends the package handling so that this information can be
added as an additional argument during packages generation.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
package/firmware/linux-firmware/Makefile

index d056140f45bf9282532006f5ffc412b5327248ac..b86177b91adcb17b38670a7f01436761314f99b0 100644 (file)
@@ -30,6 +30,8 @@ define Package/firmware-default
   URL:=http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git
   TITLE:=$(1)
   DEPENDS:=$(2)
+  LICENSE_FILES:=$(3)
+  LICENSE:=$(4)
 endef
 
 define Build/Compile