u-boot.mk: do not force parallel build
authorMartin Schiller <ms@dev.tdt.de>
Thu, 16 Nov 2023 13:10:46 +0000 (14:10 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 19 Nov 2023 16:18:30 +0000 (17:18 +0100)
Some patched u-boots may have problems with parallel build.
Do not enforce parallel build here so one can set PKG_BUILD_PARALLEL:=0
in the specific u-boot Makefile also before including the u-boot.mk.

Signed-off-by: Martin Schiller <ms@dev.tdt.de>
include/u-boot.mk

index 2b8106410f592182ad7dc0691f6cfdd47ec695f1..280c6e35a106d642d0c4c1ebc8698120f47e7c78 100644 (file)
@@ -16,7 +16,7 @@ PKG_FLAGS:=nonshared
 PKG_LICENSE:=GPL-2.0 GPL-2.0+
 PKG_LICENSE_FILES:=Licenses/README
 
-PKG_BUILD_PARALLEL:=1
+PKG_BUILD_PARALLEL ?= 1
 
 export GCC_HONOUR_COPTS=s