firewall/firewall4: provide uci-firewall
authorStijn Tintel <stijn@linux-ipv6.be>
Mon, 18 Oct 2021 22:42:02 +0000 (00:42 +0200)
committerStijn Tintel <stijn@linux-ipv6.be>
Thu, 6 Jan 2022 12:54:50 +0000 (14:54 +0200)
Provide uci-firewall via PROVIDES in both firewall and firewall4. This
will allow us to change the dependency of luci-app-firewall to
uci-firewall, making it possible to use it with either implementation.

Move CONFLICTS from firewall4 to firewall, to solve this recursive
dependency problem:

tmp/.config-package.in:307:error: recursive dependency detected!
tmp/.config-package.in:307:     symbol PACKAGE_firewall is selected by PACKAGE_firewall4
tmp/.config-package.in:328:     symbol PACKAGE_firewall4 depends on PACKAGE_firewall

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Reviewed-by: Jo-Philipp Wich <jo@mein.io>
package/network/config/firewall/Makefile
package/network/config/firewall4/Makefile

index 378a912f9d058e3379549a9a7575d2f3f66b078b..815e33604cedd123fade92f66636fa64f9106246 100644 (file)
@@ -9,7 +9,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=firewall
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/firewall3.git
@@ -29,6 +29,8 @@ define Package/firewall
   CATEGORY:=Base system
   TITLE:=OpenWrt C Firewall
   DEPENDS:=+libubox +libubus +libuci +libip4tc +IPV6:libip6tc +libxtables +kmod-ipt-core +kmod-ipt-conntrack +IPV6:kmod-nf-conntrack6 +kmod-ipt-nat
+  PROVIDES:=uci-firewall
+  CONFLICTS:=firewall4
 endef
 
 define Package/firewall/description
index c95a15a83993d0db1ee904b2f7e004d1111a928f..d7f8334dfce6ff6c4e70180176765fbbb56bfbdb 100644 (file)
@@ -26,7 +26,7 @@ define Package/firewall4
        +kmod-nft-nat +kmod-nft-nat6 \
        +nftables-json \
        +ucode +ucode-mod-fs +ucode-mod-ubus +ucode-mod-uci
-  CONFLICTS:=firewall
+  PROVIDES:=uci-firewall
 endef
 
 define Package/firewall4/description