tools/fakeroot: update to 1.30.1
authorNick Hainke <vincent@systemli.org>
Fri, 4 Nov 2022 22:34:02 +0000 (23:34 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 5 Nov 2022 14:07:46 +0000 (14:07 +0000)
Release Notes:
https://tracker.debian.org/news/1381350/accepted-fakeroot-1301-1-source-into-unstable/

Refresh patches:
- 600-macOS.patch

Signed-off-by: Nick Hainke <vincent@systemli.org>
tools/fakeroot/Makefile
tools/fakeroot/patches/600-macOS.patch

index efd9227d1a907470455c5166c23d0662a0282cdb..66ccbcb50d68227b76d4b29a34a5d432cd37e753 100644 (file)
@@ -5,12 +5,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fakeroot
-PKG_VERSION:=1.29
+PKG_VERSION:=1.30.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=@DEBIAN/pool/main/f/fakeroot
-PKG_HASH:=8fbbafb780c9173e3ace4a04afbc1d900f337f3216883939f5c7db3431be7c20
+PKG_HASH:=32ebb1f421aca0db7141c32a8c104eb95d2b45c393058b9435fbf903dd2b6a75
 PKG_LICENSE:=GPL-3.0-or-later
 PKG_LICENSE_FILES:=COPYING
 PKG_FIXUP:=autoreconf
index 730367f07c7fadbd2f8fb66213cf36473da18535..5cfcc8128485a93fb9071a0eede157b63a8951f0 100644 (file)
@@ -24,7 +24,7 @@
  #include <spawn.h>
 --- a/wrapfunc.inp
 +++ b/wrapfunc.inp
-@@ -48,9 +48,11 @@ getattrlist$UNIX2003;int;(const char *pa
+@@ -50,9 +50,11 @@ getattrlist$UNIX2003;int;(const char *pa
  #endif
  #endif
  #if MAC_OS_X_VERSION_MIN_REQUIRED >= MAC_OS_X_VERSION_10_5
@@ -36,7 +36,7 @@
  posix_spawn;int;(pid_t * __restrict pid, const char * __restrict path, const posix_spawn_file_actions_t *file_actions, const posix_spawnattr_t * __restrict attrp, char *const argv[ __restrict], char *const envp[ __restrict]);(pid, path, file_actions, attrp, argv, envp)
  posix_spawnp;int;(pid_t * __restrict pid, const char * __restrict path, const posix_spawn_file_actions_t *file_actions, const posix_spawnattr_t * __restrict attrp, char *const argv[ __restrict], char *const envp[ __restrict]);(pid, path, file_actions, attrp, argv, envp)
  #endif
-@@ -229,7 +231,7 @@ facl;int;(int fd, int cmd, int cnt, void
+@@ -231,7 +233,7 @@ facl;int;(int fd, int cmd, int cnt, void
  #ifdef HAVE_FTS_READ
  fts_read;FTSENT *;(FTS *ftsp);(ftsp)
  #ifdef __APPLE__
@@ -45,7 +45,7 @@
  fts_read$INODE64;FTSENT *;(FTS *ftsp);(ftsp)
  #endif
  #endif /* ifdef __APPLE__ */
-@@ -237,7 +239,7 @@ fts_read$INODE64;FTSENT *;(FTS *ftsp);(f
+@@ -239,7 +241,7 @@ fts_read$INODE64;FTSENT *;(FTS *ftsp);(f
  #ifdef HAVE_FTS_CHILDREN
  fts_children;FTSENT *;(FTS *ftsp, int options);(ftsp, options)
  #ifdef __APPLE__