tools: libdeflate: fetch source as tarball
authorRobert Marko <robimarko@gmail.com>
Thu, 4 Apr 2024 09:14:55 +0000 (11:14 +0200)
committerRobert Marko <robimarko@gmail.com>
Sat, 6 Apr 2024 09:24:18 +0000 (11:24 +0200)
libdeflate is currently intentionally being fetched via GIT.

However, with the move to using ZSTD to compress the cloned GIT repo
tarballs it means that we would first need to compile ZSTD.
But that means that we need to be able to unpack gzipped tarballs first
which we currently do by using libdeflate-gzip.
So, in order to do so lets fetch libdeflate as a tarball, use gzip to
extract it and then use libdeflate as regular for all other tools.

Signed-off-by: Robert Marko <robimarko@gmail.com>
tools/libdeflate/Makefile

index 5da6c693eacbeb88a5ba129cfc7def51ae7a560e..fbf8bde984430ad5f185f9ee64094f44dea5ea44 100644 (file)
@@ -10,13 +10,14 @@ PKG_NAME:=libdeflate
 PKG_VERSION:=1.19
 PKG_RELEASE:=1
 
-PKG_SOURCE_URL:=https://github.com/ebiggers/libdeflate.git
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=v$(PKG_VERSION)
-PKG_MIRROR_HASH:=5aac9801815384a5e417c8345d25d07547648e28403566ef73a46295ec26b6c4
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/ebiggers/libdeflate/releases/download/v$(PKG_VERSION)
+PKG_HASH:=d9bb9bdd8cc5a8c1f7f6226fa0053dd72861e15f366e7ff7d0d191eac16d66f3
 
 include $(INCLUDE_DIR)/host-build.mk
 
+DECOMPRESS_CMD:=$(STAGING_DIR_HOST)/bin/gzip -dc $(DL_DIR)/$(PKG_SOURCE) |
+
 define Host/Compile
        $(HOSTCC_NOCACHE) $(HOST_CFLAGS) $(HOST_LDFLAGS) \
        $(HOST_BUILD_DIR)/lib/*{,/*}.c \