mpc85xx: refresh 6.1 patches
authorPawel Dembicki <paweldembicki@gmail.com>
Tue, 21 Nov 2023 09:43:46 +0000 (10:43 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Fri, 8 Mar 2024 16:24:13 +0000 (17:24 +0100)
Most changes done by "make target/linux/refresh"

Manually refreshed:
102-powerpc-add-cmdline-override.patch

Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
target/linux/mpc85xx/patches-6.1/100-powerpc-85xx-tl-wdr4900-v1-support.patch
target/linux/mpc85xx/patches-6.1/101-powerpc-85xx-hiveap-330-support.patch
target/linux/mpc85xx/patches-6.1/102-powerpc-add-cmdline-override.patch
target/linux/mpc85xx/patches-6.1/103-powerpc-85xx-red-15w-rev1.patch
target/linux/mpc85xx/patches-6.1/105-powerpc-85xx-panda-support.patch
target/linux/mpc85xx/patches-6.1/106-powerpc-85xx-ws-ap3710i-support.patch
target/linux/mpc85xx/patches-6.1/107-powerpc-85xx-add-ws-ap3825i-support.patch
target/linux/mpc85xx/patches-6.1/108-powerpc-85xx-firebox-t10-support.patch.patch
target/linux/mpc85xx/patches-6.1/109-powerpc-85xx-add-ws-ap3715i-support.patch
target/linux/mpc85xx/patches-6.1/110-powerpc-85xx-br200-wp-support.patch
target/linux/mpc85xx/patches-6.1/900-powerpc-bootwrapper-disable-uImage-generation.patch

index 0ecbec3ca413c2face85849ad1397db54577f029..7b9016d2fee26148f5dcd256ccea8ea2421ca034 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
 
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -163,6 +163,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
+@@ -179,6 +179,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
  src-plat-$(CONFIG_PPC_POWERNV) += pseries-head.S
  src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
  src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
@@ -27,7 +27,7 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
  
  src-plat-$(CONFIG_PPC_MICROWATT) += fixed-head.S microwatt.c
  
-@@ -343,7 +344,7 @@ image-$(CONFIG_TQM8548)                    += cuImage.tqm
+@@ -359,7 +360,7 @@ image-$(CONFIG_TQM8548)                    += cuImage.tqm
  image-$(CONFIG_TQM8555)                       += cuImage.tqm8555
  image-$(CONFIG_TQM8560)                       += cuImage.tqm8560
  image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
@@ -38,7 +38,7 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
  
 --- a/arch/powerpc/boot/wrapper
 +++ b/arch/powerpc/boot/wrapper
-@@ -339,6 +339,11 @@ adder875-redboot)
+@@ -341,6 +341,11 @@ adder875-redboot)
      platformo="$object/fixed-head.o $object/redboot-8xx.o"
      binary=y
      ;;
@@ -52,7 +52,7 @@ Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
      binary=y
 --- a/arch/powerpc/platforms/85xx/Kconfig
 +++ b/arch/powerpc/platforms/85xx/Kconfig
-@@ -170,6 +170,18 @@ config STX_GP3
+@@ -163,6 +163,18 @@ config STX_GP3
        select CPM2
        select DEFAULT_UIMAGE
  
index da95cd2716210954129a953b288d567e49573443..fe8745361d081d2230fee51c25b71d2a19ee7da4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/powerpc/platforms/85xx/Kconfig
 +++ b/arch/powerpc/platforms/85xx/Kconfig
-@@ -49,6 +49,17 @@ config BSC9132_QDS
+@@ -40,6 +40,17 @@ config BSC9132_QDS
          and dual StarCore SC3850 DSP cores.
          Manufacturer : Freescale Semiconductor, Inc
  
index 0d26dc85015296fd8ddd7931563995a989ba452f..b83e5f86d2e7013f6dc89f4b86841a10299a7e05 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/powerpc/Kconfig
 +++ b/arch/powerpc/Kconfig
-@@ -915,6 +915,14 @@ config CMDLINE_FORCE
+@@ -954,6 +954,14 @@ config CMDLINE_FORCE
  
  endchoice
  
@@ -17,9 +17,9 @@
        help
 --- a/drivers/of/fdt.c
 +++ b/drivers/of/fdt.c
-@@ -1162,6 +1162,17 @@ int __init early_init_dt_scan_chosen(uns
+@@ -1187,6 +1187,17 @@ int __init early_init_dt_scan_chosen(cha
        if (p != NULL && l > 0)
-               strlcat(data, p, min_t(int, strlen(data) + (int)l, COMMAND_LINE_SIZE));
+               strlcat(cmdline, p, min_t(int, strlen(cmdline) + (int)l, COMMAND_LINE_SIZE));
  
 +    /* CONFIG_CMDLINE_OVERRIDE is used to fallback to a different
 +     * device tree option of chosen/bootargs-override. This is
@@ -29,9 +29,9 @@
 +#ifdef CONFIG_CMDLINE_OVERRIDE
 +      p = of_get_flat_dt_prop(node, "bootargs-override", &l);
 +      if (p != NULL && l > 0)
-+              strlcpy(data, p, min((int)l, COMMAND_LINE_SIZE));
++              strlcpy(cmdline, p, min((int)l, COMMAND_LINE_SIZE));
 +#endif
 +
+ handle_cmdline:
        /*
         * CONFIG_CMDLINE is meant to be a default in case nothing else
-        * managed to set the command line, unless CONFIG_CMDLINE_FORCE
index 66044878eb61263381617dbc8811d6a2965847fd..711d98abe750347df0fe921dc51be6d589d15715 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/powerpc/platforms/85xx/Kconfig
 +++ b/arch/powerpc/platforms/85xx/Kconfig
-@@ -173,6 +173,16 @@ config XES_MPC85xx
+@@ -166,6 +166,16 @@ config XES_MPC85xx
          Manufacturer: Extreme Engineering Solutions, Inc.
          URL: <https://www.xes-inc.com/>
  
index 4913c614a803255f3344acc36d0ca653e16e8c66..3c24a373aba759948cefec979c6d8fb89fc583db 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/powerpc/platforms/85xx/Kconfig
 +++ b/arch/powerpc/platforms/85xx/Kconfig
-@@ -60,6 +60,17 @@ config HIVEAP_330
+@@ -51,6 +51,17 @@ config HIVEAP_330
        This board is a Concurrent Dual-Band wireless access point with a
        Freescale P1020 SoC.
  
index 124376ffd9972e3a9cd0a5dffca8a734594fbfd2..5ac3f2f2d9419df6a1f702d1db4fc050e7ae4a6e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/powerpc/platforms/85xx/Kconfig
 +++ b/arch/powerpc/platforms/85xx/Kconfig
-@@ -71,6 +71,17 @@ config PANDA
+@@ -62,6 +62,17 @@ config PANDA
          This board is a Concurrent Dual-Band wireless access point with a
          Freescale P1020 SoC.
  
index bd731a23445026031d04febcbafcb2b4f96437fe..0fa1b4172b8fb2765eff50c4dc39df7d9d30a943 100644 (file)
@@ -8,7 +8,7 @@ WS-AP3825i AP.
 
 --- a/arch/powerpc/platforms/85xx/Kconfig
 +++ b/arch/powerpc/platforms/85xx/Kconfig
-@@ -82,6 +82,16 @@ config WS_AP3710I
+@@ -73,6 +73,16 @@ config WS_AP3710I
          This board is a Concurrent Dual-Band wireless access point with a
          Freescale P1020 SoC.
  
@@ -37,7 +37,7 @@ WS-AP3825i AP.
  obj-$(CONFIG_RED_15W_REV1)    += red15w_rev1.o
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -164,6 +164,7 @@ src-plat-$(CONFIG_PPC_POWERNV) += pserie
+@@ -180,6 +180,7 @@ src-plat-$(CONFIG_PPC_POWERNV) += pserie
  src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
  src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
  src-plat-$(CONFIG_TL_WDR4900_V1) += simpleboot.c fixed-head.S
@@ -45,7 +45,7 @@ WS-AP3825i AP.
  
  src-plat-$(CONFIG_PPC_MICROWATT) += fixed-head.S microwatt.c
  
-@@ -345,6 +346,7 @@ image-$(CONFIG_TQM8555)                    += cuImage.tqm
+@@ -361,6 +362,7 @@ image-$(CONFIG_TQM8555)                    += cuImage.tqm
  image-$(CONFIG_TQM8560)                       += cuImage.tqm8560
  image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
  image-$(CONFIG_TL_WDR4900_V1)         += simpleImage.tl-wdr4900-v1
@@ -55,7 +55,7 @@ WS-AP3825i AP.
  
 --- a/arch/powerpc/boot/wrapper
 +++ b/arch/powerpc/boot/wrapper
-@@ -339,6 +339,7 @@ adder875-redboot)
+@@ -341,6 +341,7 @@ adder875-redboot)
      platformo="$object/fixed-head.o $object/redboot-8xx.o"
      binary=y
      ;;
index b074113eaa5a9f8c2fd97a03cbe576351d7116c0..0b3a93b8486adcbccf0a928f62460db0f83282f8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/powerpc/platforms/85xx/Kconfig
 +++ b/arch/powerpc/platforms/85xx/Kconfig
-@@ -92,6 +92,16 @@ config WS_AP3825I
+@@ -83,6 +83,16 @@ config WS_AP3825I
          This board is a Concurrent Dual-Band wireless access point with a
          Freescale P1020 SoC.
  
index 692cef0417db828122453d319f6e1282c9018f5f..8f34f14d5400e28f87f8efbab1b3da57ed6f0aa7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/powerpc/platforms/85xx/Kconfig
 +++ b/arch/powerpc/platforms/85xx/Kconfig
-@@ -82,6 +82,17 @@ config WS_AP3710I
+@@ -73,6 +73,17 @@ config WS_AP3710I
          This board is a Concurrent Dual-Band wireless access point with a
          Freescale P1020 SoC.
  
@@ -30,7 +30,7 @@
  obj-$(CONFIG_CORENET_GENERIC)   += corenet_generic.o
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -346,6 +346,7 @@ image-$(CONFIG_TQM8555)                    += cuImage.tqm
+@@ -362,6 +362,7 @@ image-$(CONFIG_TQM8555)                    += cuImage.tqm
  image-$(CONFIG_TQM8560)                       += cuImage.tqm8560
  image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
  image-$(CONFIG_TL_WDR4900_V1)         += simpleImage.tl-wdr4900-v1
@@ -40,7 +40,7 @@
  image-$(CONFIG_MVME7100)                += dtbImage.mvme7100
 --- a/arch/powerpc/boot/wrapper
 +++ b/arch/powerpc/boot/wrapper
-@@ -339,6 +339,7 @@ adder875-redboot)
+@@ -341,6 +341,7 @@ adder875-redboot)
      platformo="$object/fixed-head.o $object/redboot-8xx.o"
      binary=y
      ;;
index eb70a4c4c47890148e8e50519e479aa36593fe93..430af1efb133f7769876a41ac41b3e80f97040d3 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/powerpc/platforms/85xx/Kconfig
 +++ b/arch/powerpc/platforms/85xx/Kconfig
-@@ -49,6 +49,16 @@ config BSC9132_QDS
+@@ -40,6 +40,16 @@ config BSC9132_QDS
          and dual StarCore SC3850 DSP cores.
          Manufacturer : Freescale Semiconductor, Inc
  
@@ -29,7 +29,7 @@
  obj-$(CONFIG_MPC8560_ADS) += mpc85xx_ads.o
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -163,6 +163,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
+@@ -179,6 +179,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie
  src-plat-$(CONFIG_PPC_POWERNV) += pseries-head.S
  src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
  src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c
@@ -37,7 +37,7 @@
  src-plat-$(CONFIG_TL_WDR4900_V1) += simpleboot.c fixed-head.S
  src-plat-$(CONFIG_WS_AP3825I) += simpleboot.c fixed-head.S
  
-@@ -345,6 +346,7 @@ image-$(CONFIG_TQM8548)                    += cuImage.tqm
+@@ -361,6 +362,7 @@ image-$(CONFIG_TQM8548)                    += cuImage.tqm
  image-$(CONFIG_TQM8555)                       += cuImage.tqm8555
  image-$(CONFIG_TQM8560)                       += cuImage.tqm8560
  image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
@@ -47,7 +47,7 @@
  image-$(CONFIG_WS_AP3825I)            += simpleImage.ws-ap3825i
 --- a/arch/powerpc/boot/wrapper
 +++ b/arch/powerpc/boot/wrapper
-@@ -339,6 +339,7 @@ adder875-redboot)
+@@ -341,6 +341,7 @@ adder875-redboot)
      platformo="$object/fixed-head.o $object/redboot-8xx.o"
      binary=y
      ;;
index 1af5aefe0bdda14948f1a526dc255a0a9370582b..f1e0f73f88cb5b07559a473bc1bd771aad1656ce 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -274,7 +274,6 @@ image-$(CONFIG_PPC_CHRP)           += zImage.chrp
+@@ -290,7 +290,6 @@ image-$(CONFIG_PPC_CHRP)           += zImage.chrp
  image-$(CONFIG_PPC_EFIKA)             += zImage.chrp
  image-$(CONFIG_PPC_PMAC)              += zImage.pmac
  image-$(CONFIG_PPC_HOLLY)             += dtbImage.holly
@@ -24,7 +24,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
  image-$(CONFIG_EPAPR_BOOT)            += zImage.epapr
  
  #
-@@ -409,15 +408,6 @@ $(obj)/dtbImage.%: vmlinux $(wrapperbits
+@@ -425,15 +424,6 @@ $(obj)/dtbImage.%: vmlinux $(wrapperbits
  $(obj)/vmlinux.strip: vmlinux
        $(STRIP) -s -R .comment $< -o $@