d1: define subtarget specifically
authorPaul Spooren <mail@aparcar.org>
Mon, 8 Apr 2024 05:54:45 +0000 (07:54 +0200)
committerPaul Spooren <mail@aparcar.org>
Mon, 8 Apr 2024 19:52:51 +0000 (21:52 +0200)
Historically it's possible to leave the `SUBTARGETS` undefined and
automatically fallback to a "generic" subtarget. This however breaks
various downstream scripts which may have expectations around filenames:

While some targets with an explicit generic subtarget contain `generic`
in the filenames of artifacts, implicit "subtargets" don't.

Right now this breaks the CI[1], possibly also scripts using the ImageBuilders.

Do to the D1 target what's done to other target, explicitly define the
"generic" subtarget.

[1]: https://github.com/openwrt/openwrt/actions/runs/8592821105/job/23548273630

Signed-off-by: Paul Spooren <mail@aparcar.org>
target/linux/d1/Makefile
target/linux/d1/generic/target.mk [new file with mode: 0644]

index 436ab9486233104b51f15abb354ed32f1ec4d103..69e28d48116d49d2a7340dc813bb85e7a34c3398 100644 (file)
@@ -9,6 +9,7 @@ BOARD:=d1
 BOARDNAME:=AllWinner D1 RISC-V SoC
 FEATURES:=ext4 squashfs
 KERNELNAME:=Image dtbs
+SUBTARGETS:=generic
 
 KERNEL_PATCHVER:=6.1
 
diff --git a/target/linux/d1/generic/target.mk b/target/linux/d1/generic/target.mk
new file mode 100644 (file)
index 0000000..f5cb1fb
--- /dev/null
@@ -0,0 +1 @@
+BOARDNAME:=Generic