mxs: adjust DTS path for 6.6
authorZoltan HERPAI <wigyori@uid0.hu>
Thu, 18 Apr 2024 16:49:27 +0000 (16:49 +0000)
committerZoltan HERPAI <wigyori@uid0.hu>
Fri, 19 Apr 2024 16:32:42 +0000 (18:32 +0200)
For the ARM arch on 6.6, DTS files are moved into their vendor directories,
mimicking arm64. Reflect this in the image Makefile.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
target/linux/mxs/image/Makefile

index f1847dec1eda0a8ab61d232fe08e5be9f5cc997e..585211dc0bc810a64ceb883645df092c84593182 100644 (file)
@@ -39,6 +39,9 @@ define Device/Default
   KERNEL_NAME := zImage
   KERNEL := kernel-bin | uImage none
   IMAGES := sdcard.img.gz
+ifneq ($(KERNEL),6.1)
+  DTS_DIR := $(DTS_DIR)/nxp/mxs
+endif
   DEVICE_DTS = $$(SOC)-$(lastword $(subst _, ,$(1)))
 endef