tools/cmake: disable xcode generator
authorFelix Fietkau <nbd@nbd.name>
Sun, 24 Mar 2024 09:59:22 +0000 (10:59 +0100)
committerFelix Fietkau <nbd@nbd.name>
Fri, 29 Mar 2024 14:40:25 +0000 (15:40 +0100)
Fixes build on latest macOS SDK

Signed-off-by: Felix Fietkau <nbd@nbd.name>
tools/cmake/patches/160-disable_xcode_generator.patch [new file with mode: 0644]

diff --git a/tools/cmake/patches/160-disable_xcode_generator.patch b/tools/cmake/patches/160-disable_xcode_generator.patch
new file mode 100644 (file)
index 0000000..20d1086
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/Source/CMakeLists.txt
++++ b/Source/CMakeLists.txt
+@@ -846,7 +846,7 @@ if(CMake_USE_XCOFF_PARSER)
+ endif()
+ # Xcode only works on Apple
+-if(APPLE)
++if(APPLE_DISABLED)
+   target_sources(
+     CMakeLib
+     PRIVATE
+--- a/Source/cmake.cxx
++++ b/Source/cmake.cxx
+@@ -132,7 +132,7 @@
+ #  include "cmGlobalGhsMultiGenerator.h"
+ #endif
+-#if defined(__APPLE__)
++#if defined(__APPLE_DISABLED__)
+ #  if !defined(CMAKE_BOOTSTRAP)
+ #    include "cmGlobalXCodeGenerator.h"